Pi now fails to boot

Raspberry Pi is now failing to boot after the latest OSMC update.

Unable to access the pi from FTP either. It’s simply not starting up the OS Even… So no access is possible.

Any Suggestions would be appreciated.??

Sounds like a failed SD Card.
If the device is not booting not much you can do. You could try to read the SD Card in your PC

Thanks… but it’s not a failed SD card… It was all working fine half an hour ago… then I ran the OSMC update. And it appeared to complete, then it re-booted and just stops with no OS booting.

The SD card is only used, for the boot. The OS and files are on a hard drive.

Well than you want to explain a bit more what you see on screen and how far the boot process gets.
Also check HDD connection and maybe run a disk check from PC

Thanks… Already done all that… results don’t show any hardware problems at all… The boot gets as far as a blank screen and a flashing cursor. Nothing else. No attempt to access the HD gets made and the SD card doesn’t seem to be firing up the system at all. All hardware connections are good.

I think I may well try an install from scratch… It looks very much like the update failed and didn’t write the boot onto the SD card after deleting the earlier version. But thanks! all suggestions appreciated.

What are the files you see on the SD card if you plug it into your PC?

It should be something like this

bcm2708-rpi-0-w.dtb     bcm2835-rpi-b.dtb       config-4.14.15-5-osmc  LICENCE.broadcom
bcm2708-rpi-b.dtb       bcm2835-rpi-b-plus.dtb  config-4.9.29-15-osmc  overlays
bcm2708-rpi-b-plus.dtb  bcm2835-rpi-b-rev2.dtb  config.txt             preseed.cfg
bcm2708-rpi-cm.dtb      bcm2835-rpi-zero.dtb    config.txt.working     start_x.elf
bcm2709-rpi-2-b.dtb     bcm2835-rpi-zero-w.dtb  dtb-4.14.15-5-osmc     System.map-4.14.15-5-osmc
bcm2710-rpi-3-b.dtb     bcm2836-rpi-2-b.dtb     dtb-4.9.29-15-osmc     System.map-4.9.29-15-osmc
bcm2710-rpi-cm3.dtb     bcm2837-rpi-3-b.dtb     fixup_x.dat            vmlinuz-4.14.15-5-osmc
bcm2835-rpi-a.dtb       bootcode.bin            install.log            vmlinuz-4.9.29-15-osmc
bcm2835-rpi-a-plus.dtb  cmdline.txt             kernel.img

Yes… Something a lot like that and a lot of other files as well.

What kind of files? Maybe you ran out of space?

They’re all OSMC stuff … Used space is only 32megs… So no there’s plenty of storage space on there.

config files and boot files… some OSMC folders… with install files… nothing out of the ordinary that I can see.

Than it should boot
Here more detailed view with the sizes of the files

-rwxr-xr-x  1 root root  22K Mar  4 18:10 bcm2708-rpi-0-w.dtb
-rwxr-xr-x  1 root root  22K Mar  4 18:10 bcm2708-rpi-b.dtb
-rwxr-xr-x  1 root root  22K Mar  4 18:10 bcm2708-rpi-b-plus.dtb
-rwxr-xr-x  1 root root  22K Mar  4 18:10 bcm2708-rpi-cm.dtb
-rwxr-xr-x  1 root root  23K Mar  4 18:10 bcm2709-rpi-2-b.dtb
-rwxr-xr-x  1 root root  24K Mar  4 18:10 bcm2710-rpi-3-b.dtb
-rwxr-xr-x  1 root root  23K Mar  4 18:10 bcm2710-rpi-cm3.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-a.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-a-plus.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-b.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-b-plus.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-b-rev2.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-zero.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2835-rpi-zero-w.dtb
-rwxr-xr-x  1 root root  18K Mar  4 18:10 bcm2836-rpi-2-b.dtb
-rwxr-xr-x  1 root root  17K Mar  4 18:10 bcm2837-rpi-3-b.dtb
-rwxr-xr-x  1 root root  51K Feb  2 00:45 bootcode.bin
-rwxr-xr-x  1 root root   63 Jan  1  1980 cmdline.txt
-rwxr-xr-x  1 root root 133K Mar  4 16:13 config-4.14.15-5-osmc
-rwxr-xr-x  1 root root 126K Jan 21 05:17 config-4.9.29-15-osmc
-rwxr-xr-x  1 root root  111 Mar  6 20:48 config.txt
-rwxr-xr-x  1 root root  111 Feb  2 20:53 config.txt.working
drwxr-xr-x  3 root root 2.5K Mar  6 20:45 dtb-4.14.15-5-osmc
drwxr-xr-x  3 root root 2.0K Feb  5 16:28 dtb-4.9.29-15-osmc
-rwxr-xr-x  1 root root 9.5K Feb  2 00:45 fixup_x.dat
-rwxr-xr-x  1 root root 2.3K Jan  1  1980 install.log
-rwxr-xr-x  1 root root 7.9M Mar  6 20:47 kernel.img
-rwxr-xr-x  1 root root 1.5K Feb  2 00:45 LICENCE.broadcom
drwxr-xr-x  2 root root  13K Mar  6 20:45 overlays
-rwxr-xr-x  1 root root  218 Jan  1  1980 preseed.cfg
-rwxr-xr-x  1 root root 3.8M Feb  2 00:45 start_x.elf
-rwxr-xr-x  1 root root 2.0M Mar  4 17:39 System.map-4.14.15-5-osmc
-rwxr-xr-x  1 root root 2.1M Jan 21 05:54 System.map-4.9.29-15-osmc
-rwxr-xr-x  1 root root 7.9M Mar  4 17:39 vmlinuz-4.14.15-5-osmc
-rwxr-xr-x  1 root root 7.5M Jan 21 05:54 vmlinuz-4.9.29-15-osmc

Yeah they all seem to be there… just checked through. It’s probably a configuration file somewhere that isn’t reading right… I’ve not had chance to go through them all but at first glance all seems OK.

The quickest route is going to be a re-install from scratch I think. Doesn’t exactly tell me or anybody else why it happened but it’s probably the best bet for getting it running in the quickest time. Unless there are any of the configuration files you would like to see the content of? If that won’t help then I’ll plough on with the re-install and see where it takes us.

Go ahead with reinstall

Yes… It was a failed update… No idea what the cause of the failure was but having done a re-install it’s now booting and running properly again… now on to a fun day of setting it all back up again!! :frowning:

Oh well… if my experience is common on this one… I’m guessing there will be few more over the next few days.

Thanks for the help.

Well you just could have backed up your /home/osmc/.kodi folder from the harddisk and restore it. Than all settings would have been saved.
Also maybe consider in the future to use the MyOSMC Backup tool.

As the update is already 2 days old I assume till now there have been several thousand Raspberry updates. So I believe a localised case.

1 Like

My pi3 was shitcanned after the update too. Checked sd card and everything was fine. Wiped and reinstalled. Then updated and had an issue at boot with screen flicker. Changed resolution to 720p fixed it. Then back to 1080p and it seems stable now. Not sure what happened but it’s back. Wasn’t able to ssh into the pi when it wouldn’t boot so cant really give any more info on what may have happened.

Yeah… looks like this is a genuine issue with the update, exactly the same here… update bricks the Pi boot, so it’s impossible to SSH in to try and fix it. It’s just not booting to the OS so there’s no way you can then access KODI files. Except by hardware intervention by connecting the card and in my case hard drive as well to a PC.

Just off to do another re-install… All part of the fun! :slight_smile:

Check content of cmdline.txt and config.txt if this happens.
I know we have done a few updates in Slack without issue.

Update went fine with my pi

Is your install a pure SDcard install or a USB install? OP’s report is specific in that his install is on USB.

Hi Sam, yes I took a look at those after the second time the update wrecked things… I couldn’t see anything odd… but like a complete idiot, I didn’t keep a copy of them before I did a further re-install otherwise I’d post them for people to take a look.

As it is right now, it’s running again and everything is re-installed. (I even took an HD backup… not like me to do that) … I’ve shut off updates until I’m certain we have one that works properly with an SD boot + USB hard drive.

Thanks for looking at it!