Pi now fails to boot

Go ahead with reinstall

Yes… It was a failed update… No idea what the cause of the failure was but having done a re-install it’s now booting and running properly again… now on to a fun day of setting it all back up again!! :frowning:

Oh well… if my experience is common on this one… I’m guessing there will be few more over the next few days.

Thanks for the help.

Well you just could have backed up your /home/osmc/.kodi folder from the harddisk and restore it. Than all settings would have been saved.
Also maybe consider in the future to use the MyOSMC Backup tool.

As the update is already 2 days old I assume till now there have been several thousand Raspberry updates. So I believe a localised case.

1 Like

My pi3 was shitcanned after the update too. Checked sd card and everything was fine. Wiped and reinstalled. Then updated and had an issue at boot with screen flicker. Changed resolution to 720p fixed it. Then back to 1080p and it seems stable now. Not sure what happened but it’s back. Wasn’t able to ssh into the pi when it wouldn’t boot so cant really give any more info on what may have happened.

Yeah… looks like this is a genuine issue with the update, exactly the same here… update bricks the Pi boot, so it’s impossible to SSH in to try and fix it. It’s just not booting to the OS so there’s no way you can then access KODI files. Except by hardware intervention by connecting the card and in my case hard drive as well to a PC.

Just off to do another re-install… All part of the fun! :slight_smile:

Check content of cmdline.txt and config.txt if this happens.
I know we have done a few updates in Slack without issue.

Update went fine with my pi

Is your install a pure SDcard install or a USB install? OP’s report is specific in that his install is on USB.

Hi Sam, yes I took a look at those after the second time the update wrecked things… I couldn’t see anything odd… but like a complete idiot, I didn’t keep a copy of them before I did a further re-install otherwise I’d post them for people to take a look.

As it is right now, it’s running again and everything is re-installed. (I even took an HD backup… not like me to do that) … I’ve shut off updates until I’m certain we have one that works properly with an SD boot + USB hard drive.

Thanks for looking at it!

I attempted to update two Pi’s today and both were bricked by the update. Not sure at this point how to recover. Any thoughts?

I always update as soon as I receive the email informing me of availability and have never had an issue like this before. I did leave each of them on for several hours hoping the issue would self-correct but it never did. Please help!

Thanks.

First step to identify what is wrong. Plug the SD card into your PC and post here the exact directory output including filesize.

Also important to know if you used a SD Only or SD + USB Disk install?

@slwalls,

moved your post here as this seems to be similar issues

Thanks. Will check tomorrow on PC between meetings. It was an SD only install over wifi. Has always worked like a charm…up to now!

So, I am trying to look at the card on the first Pi and my computer asks if I would like to format it. Appears the programs are all corrupt and I must start over now. Hope the update did not tank my sd cards.

Test it with H2Testw before you use it for a new install

so install worked on this Pi however i cannot connect to wireless. works with wired but cannot use wired on TV. Install version is january 2018

Hi. My 2 cents on the matter, related to March update on RPI2:
After update, it would only boot into a limited console with busybox, could mount the SDCard partitions but that was all. I haven’t had enough time to dig more about how to boot from there. After many restarts and modifications to cmdline.txt and overwritten kernels, finally the boot partition gave up and couldn’t be mounted anymore. So I proceeded with a fresh install on another sdcard and updated OSMC without any hassle. Then I formatted the boot partition on the old sdcard and copied the content over from the new install. And then, magically, the device booted perfectly from the old sdcard. I was happy because I hadn’t made a backup in a long time.
Don’t know about other situations with RPi devices and the March update, but in my case that’s what really worked. Probably there is something wrong with the sdcard anyway, but I will replace it rapidly. Hope this helps somebody.

Hi Livebest,
That is interesting in terms of updates and installs and I’m sure it’ll help somebody.
I’m not sure that it’s directly related to the problem here with the March update though. Yours does sound like a faulty SD card issue. Whereas my problem was one of a failed update on a Pi with the main bulk of stuff sitting on the hard drive and only the boot sitting on the SD card. That does seem to be a configuration issue with that update.

Hi,
That’s exactly the critical point: the sdcard boot partition. I forgot to mention that I ran fsck multiple times on both partitions, /boot and /root and none revealed any problems. The fun fact is that I ran a couple of win utilities (h2testw and usb flash tester) and even an dd if=/dev/mmcblk0px of=/dev/null (from another linux machine) without resulting any issues, which derailed me a bit. To the moment I still don’t know how reformatting /boot solved my issue, but it did. I’m sure I’m missing something here…

You might have some unstable memory cells on the card.