Pi Overheating With Netflix

So I’m not sure if it’s an issue with the most recent OSMC upgrade or something to do with the Netflix Add-On since I’ve upgraded and added the Add-On basically simultaneously, but while watching something on Netflix, within about 5 min, the thermometer graphic shows up in the corner and the video and audio start to get out of sync and I checked the temperature and it is elevated. I haven’t been able to to reproduce the issue streaming my personal 1080p movies through Kodi itself, and the Disney Plus Add-On also works flawlessly. I made sure to change the resolution on Netflix to 720P earlier but still get the same issue. I run a Raspberry Pi 3 with a Flirc remote dongle. I didn’t upload any logs because I’m not near the device itself but i can do it later if nobody had any ideas. Thank you so much.

I’m not sure what insight anyone might have here other than the bog standard type of stuff. Things like is your case trapping the heat, sitting on top of another hot device, overclocking settings that disable throttling, etc. The Netflix video is CPU bound so there is going to be an increase in temps but the RPi should be dialing itself back before you ever see that icon.

Pi is going to struggle with 1080p. 720p is pretty much the limit for software based decoding. Lowering the resolution should solve the problem.

I’m pretty sure there’s a heat sink in there, and it’s sitting by itself on a shelf with no heat sources nearby. I thought about elevating it so air gets underneath or adding a fan. Just never had this issue before. It’s been a long time since I messed with the overclock settings and I don’t remember doing anything drastic if at all. Isn’t there an over lock setting in the OSMC GUI?

Anything I can do to improve the chances of 720P working properly, and forgive my ignorance, but what is it about streaming something on Netflix that causes strain that Disney Plus doesn’t?

Disney+ might have a lower bitrate for its 720p content.

Unfortunately HW acceleration isn’t possible for Widevine encrypted content on Pi. A modest over lock may help, but not if you’re running in to temperature issues already.

Your best bet is to try and stop your device from getting throttled.

Is the heatsink hot? The adhesive can sometimes fail and start trapping heat instead of conducting it. If you post logs we can see if there is any overclock set. That section of My OSMC was removed some time back so you now have to manually edit to make those types of changes.

Personally I would get a Flirc case rather than a fan

1 Like

I’ll post some logs later when I get the chance. Thanks for the tips and I’ll look into the Flirc case as well.


Your not overclocked and I don’t see anything you set that should cause this issue. You might want to enable refresh rate switching in your player settings though. That should improve your picture quality and maybe reduce a bit of the load.

Not related at all, but using buffermode 1 seems a bit unusual and unnecessary. You sure you don’t want that to be 2 or 4?

Where do I change the buffer rate in the settings? Edit: Nevermind, I just remembered this was an advanced settings thing. If I remember right I set this because at the time I was having playback issues on my local network. And then as far as refresh, would that be the menu option for display refresh rate where the options are off, always, on start/stop, and on start? If so which one would I pick?

For the refresh rate setting I recommend “on start/stop”.

I’ll keep testing but this seems to have fixed it so far. Thanks so much.

1 Like