Pi shuts down after input change?

Log file: http://paste.osmc.io/hujiwopona.vhdl

  • The issue you are currently experiencing with OSMC: When I switch from OSMC to another input and then back to OSMC, I have no connectivity to my Pi via HDMI and I cannot SSH into the device. It seems to just power down.

  • What you were doing when this issue occurred: Just switching to another device.

  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.: Switch to input where OSMC is current running. As soon as you switch to another input and then switch back, there is no connectivity.

  • The device you are currently running OSMC on: Raspberry Pi 3

  • What peripherals are attached to the device? Besides an ethernet cable to my router and a power adapter to the wall, the device is plugged in via HDMI to a Sony sound receiver which is connected to my new Samsung 4K TV via ARC.

  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present? I noticed this after the last update I ran for OSMC, but… This could be because I upgraded my TV. My previous TV was a 1080p only TV and I did change some HDMI_EDID settings. I tried going into My OSMC/Pi Config and remove settings such as hdmi_force_hotplgu, hdmi_edid_file and enable hdmi_ignore_cec, but I still have the same issue.

Do you use CEC to control the Pi? If not, make sure you have it turned off the the TV.

Figured it out. My Harmony remote was reset. Argh!