Pi Zero 2 W Streaming Problem

First I would like to mention, I’m a noob and have no idea about programming, so please be patient.

Because the Pi Zero 2 is relatively new, I don’t have great expectations at the moment.

I read myself through a couple of troubleshooting but I’m too insecure to implement them. OSMC itself advises therefore not to get involved too much in GitHub, etc.

So I installed some supported and unsupported add-ons. My problem occurred with both of them. I started watching a stream and soon after a few secs. it freezes. In the beginning, it froze for a couple of secs. then continued just to freeze again, but right now it just freezes.

First I was uncertain if it’s a power-delivery issue or if it was from certain installments. Therefore I tried to be empiric as possible and connected it with different power sources, but the problem was maintained.

Then I uninstalled, reinstalled the unsupported as well the supported add-ons and the outcome was the same.
What was kind of interesting, I had once the possibility to navigate to settings>systeminformations>network and the network and internet status were both busy. Also, I recognized while this appeared, the green LED of the Pi Zero 2 W was blinking.

I hope my description will be supportive, for other users and me as well.

Further information you hopefully find here:


There is no logs with this name, maybe you misstyped

First I would check the network connection

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

Depending on the stream the Pi Zero 2 might not have the needed horse power to decode the streams

I should have double-checked it, my bad, sorry.
Here’s the updated link:

I don’t have access to the main server, due to I’m living in a community and I don’t want to interfere in the owner’s affairs. Instead, I made my laptop a hotspot and connected the Rpi.
I installed iperf3 on the sender and the receiver, and there was no signal at all. Afterward, I changed the ports, and there was still no signal.

What puzzled me, was that during the whole process, I was capable of listening to music without any complications. Watching TV and watching live streams is also not a problem.

I’m not sure if the Pi zero is 2 is too weak. I used different power sources and I was not capable of watching streams. I even used a USB A female to micro USB b male cable powered by a USB A male socket with an automatic 5V and 3amps output.

I had the Pi zero before and it was capable of showing streams and even live streams, which is so impressive to me, I couldn’t wait for the Pi zero 2!

Well in this log you seem to run out of Memory

[ 8622.918919] Out of memory: Killed process 1617 (kodi.bin)

Doesn’t sound healthy but maybe just that you Wifi has client separation activated

With “too weak” I was referring to the CPU power not the power supply.
But if the Pi Zero was able to play it that should not be the issue. But was the Pi Zero with Kodi 18 or already Kodi 19?

The problem is that the Pi Zero 2 W doesn’t have HEVC acceleration and has very limited memory. This won’t make it ideal for media centre duties.

Even a Pi 2 will likely perform better – because it would be possible to run versions of Kodi (18.x) with acceleration for HEVC and it has more memory.

It runs on the latest version of Kodi 18. It’s definitely not as fast as the Zero 2, but it was more or less what I needed. I tried to install Kodi 18 on the Zero 2, but it didn’t work.
I guess it has to do with the incompatibility of the chip architecture.

I’m not interested in 4k or whatsoever, I’m only interested in looking at what’s possible with these highly efficient SBC’s.

If you’re interested, here is the log link of the Pi Zero:

Probably there’s another version I can run on the Pi Zero 2. I won’t give up!

So I made some updates. I got myself a flirc-case because I recognized an increase in temperature. I also increased the clock speed to 4 volts and 1300mHz and some other specifications I’m not sure if they have an impact. Still, some streams run smoothly some don’t with or without hardware acceleration.

What I would like to know, if there’s a possibility to pause all other processes, running in the back, while watching a stream or video?

Here’s the log link: