Pi2 doesn't boot at all when trying to install

I’ve followed the steps of the installer from Ubuntu (osmcinstaller) on a Pi2. After inserting the sd card and powering on the Pi2, the large multicolored square appears and it gets stuck there. I’ve tried the 2015.09-2 & 2015.08-1 images with the same result.

To make sure I also downloaded the last raspbmc build and the install starts just fine with it, so it doesn’t look like a power or sd card problem. Furthermore, this Pi ran rasbmc just fine for over a year.

Any idea where I can look further?

Power supply might still be the culprit, OSMC needs more power than RaspBMC.

Although, the Pi2 should be more stable than the Pi1 and I cant think what extra power OSMC would need at the start.

(Make sure you have selected the right version for the Pi2.)

And make sure you have a Pi2 :smile:

Yes. This has happened more than once.

Yeah thanks, I might have mismatched B & 2… :confused: I’ll have another try tonight.

RaspBMC does not support Rpi2, so i’m pretty sure thats a pi1 :wink:

Not to mention the Pi 2 came out in Februrary so “ran rasbmc just fine for over a year” would not have been possible even if Raspbmc did work on a Pi 2…

So it is definitely a Pi 1.

1 Like

Looks like Sherlock takes the mission and solve the riddle.

Well, you guys nailed it down pretty quickly… I changed the model for the Pi1 and the installation went without a hitch. Many thanks!