PI2, install failed: can't mount root raspberry pi

Hello, i need your assistance guys.
I have problem with installation osmc on two sd cd cards, 64 GB and 16 GB.
First time i thought it is problem with size of 64 GB so i bought 16 GB card but i still can not finish installation.
In both cases i got installation error “install failed: can’t mount root”
I have tried many solutions osmc forum and others but it didnt work. (even installation form debian and fedora)

here is my installtion log

please help.

But what did you try first? Did you use the OSMC installer on Windows? You may find re-formatting the card with the SD-formatter app helps before running the installer.

Can you try an older install image?

thx for responding,

First i used osmc installer for windows 10 (on my pc) , next for debian and after for fedora 29. (on my business computer)

I reformatted both sd cards many times using gparted or windows tool or SD Memory Card Formatter aswell.

And yes, i tried older images too for example OSMC_TGT_rbp2_20180805.img.gz (last one from combo box in installer).

After it fails, can you mount both partitions on debian/fedora?

Are you able to install other OSs (?Raspbian)?

Blockquote After it fails, can you mount both partitions on debian/fedora?

im not sure what you asking about :wink:
after a failed installation i was able to mount sd card on debian/fedora. There were about 255MB fat 32 primary partition and rest of size was raw partition (no file system).

I did not try other OSs, let me check it and i will let you know soon.

OK, that’s helpful. So you are not getting a filesystem, despite what it says in the log.

yes, and this is very weird because it occurs at both sd cards. (16 GB and 64 GB)
i didnt mention that year ago i installed osmc on 8 GB sd card (the same pi) but this card died and i have to install os one more time

Did you try it on another linux box? Maybe something went wrong with the RPi which is causing the issue now.

I just checked installation with a 16G Sandisk card. The only difference to your log is the number of blocks the formatter is trying to squeeze in. I doubt that’s the issue, though.

Thu Jan 1 00:00:07 1970 Starting OSMC installer
Thu Jan 1 00:00:13 1970 Detecting device we are running on
Thu Jan 1 00:00:13 1970 Mounting boot filesystem
Thu Jan 1 00:00:13 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:13 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:13 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:13 1970 Found a definition for storage: sd
Thu Jan 1 00:00:13 1970 Creating root partition
Thu Jan 1 00:00:13 1970 From a root partition of /dev/mmcblk0p2, I have deduced a base device of /dev/mmcblk0
Thu Jan 1 00:00:13 1970 Determined 255 MB as end of first partition
Thu Jan 1 00:00:13 1970 Calling mkpart for device: /dev/mmcblk0 and fs: ext4 with start 257M and end 100%
Thu Jan 1 00:00:15 1970 Calling fmtpart for partition /dev/mmcblk0p2 and fstype ext4
Thu Jan 1 00:00:45 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
958464 inodes, 3826688 blocks
191334 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=3921674240
117 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables:   0/117 69/117       done                            
Writing inode tables:   0/117       done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information:   0/117  2/117  4/117  6/117       done

Thu Jan 1 00:00:45 1970 Mounting root
Thu Jan 1 00:00:45 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:00:45 1970 Using device->root: /dev/mmcblk0p2
Thu Jan 1 00:00:45 1970 Extracting files to root filesystem
Thu Jan 1 00:00:45 1970 Starting extract progress...
Thu Jan 1 00:05:28 1970 Extraction of root filesystem completed
Thu Jan 1 00:05:28 1970 Configuring bootloader
Thu Jan 1 00:05:28 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:06:03 1970 Configuring boot cmdline
Thu Jan 1 00:06:03 1970 Configuring /etc/fstab
Thu Jan 1 00:06:03 1970 Successful installation. Dumping log and rebooting system

wow that could be a reason.

im trying install rasbian using etcher right now to be sure card or raspberry is ok.

i have no idea where difference in blocks is from? im using brand new Kingston card, maybe installer or card formater works wrong. i will check this one more time

Different cards will report different capacities. Mine is a bit old so maybe the controller has shut down a few blocks.

Just really wanted to check there’s nothing wrong with the installer AFAICT.

That’s normal until the installation is run on the Pi, isn’t it?

The installation is running on the Pi. Compare OP’s log with mine.

Overlooked the “after failed installation”

i tried two installtions.
raspbian and libreelec
and both with the same error message cant mount root on device.
So im almost sure that is a sd card fault, but this card looks OK for normal usage. I mean read and write filesystem.
Everythink is OK except installation pi os.
I bought two sd cards and both are broken ? What are requirements for sd cards especially? According to specification i have Class 10 SD card and no smaller than an 8GB card.

They could be counterfeit cards, many of them falsely report themselfs as larger than they really are.

Or, your SD slot in your PC may be failing, or the slot in the Pi may have failed.

The card has probably died after long use.
OSMC 32GB SD card - OSMC will do the trick.