Pi2 just stopped working

Here goes nothing…I got a pi2 which runs besides osmc various other services like php/mysql/etc. I tried to connect to it today via putty and saw that it had crashed. Rebooted it manually and saw this:

After about a minute the OSMC logo would show up but after that I get nothing, it’s just stuck there.
Took my SD card out, hooked it up to my pc and got the latest kodi.log out:

After that I booted up Gparted and did a check on the SD card, no errors.

I can write on both partitions, even tried editing cmdline.txt to add the line “init=/bin/bash”, but that didn’t work, I still got the osmc logo.
I even tried to delete all database files from ./kodi/userdata/databases in the hope that osmc would get unstuck and continue.

Any help would be appreciated.

Looks like an old install of OSMC

I think the SD card has probably reached its end of life or is corrupted.
I would backup what you can and perform a fresh installation on a new card


The card is fairly new, it’s an EVO Class A bought mid-2021. I don’t use that pi that often…barely once every 3 months, it’s just sitting there.
Is there a ‘hacky’ way i can delete my osmc profile for it to try and recreate a new one? Or a way I can force it into terminal on boot? It would mean my whole weekend reinstalling everything and i am trying to avoid that :slight_smile:
Thanks Sam

I don’t think Kodi is your problem, I think something else is corrupted.

If you can’t SSH in to it, I’m not sure how salvageable it is…

1 Like

Ok, thanks Sam. I’ll just back up the whole card with Win32DiskImager and start fresh.