[Pi2] March 17 update HDMI Switching CEC not working

Since the March 17 update my Pi2 is causing issues with the AVR I have it plugged into.

My AVR is plugged into my HDMI 1 on my TV so it identifies my PS4 PS3 and KODI under HDMI 1.

Since the update my AVR hesitates to recognize the Kodi HDMI 1 correctly. When i switch to the Kodi HDMI 1, I can’t control anything with HDMI CEC. I have to use my Home button on my remote(which wouldn’t work if HDMI CEC was working) when I do this it looks like my Kodi HDMI 1 isn’t the one that is selected even though KODI is on the screen, it’s the one I’ve previously used. To get the HDMI CEC to work I need to reselect KODI HDMI 1, after that it works sometimes on the first try.

Also when my TV is done with something like my PS4 it usually automatically goes back to the TV’s HDMI 3 which is where my Cable Box is. With this Pi 2 plugged in it doesn’t do that anymore, it just sticks to the HDMI 1 on the TV. I know it’s the Pi2 causing this because when I unplug it from the AVR the issue goes away.

The Pi is now putting out something nasty on the HDMI since this 7.01 STABLE update.

I have a Sony TV.

This sounds like an issue with my HDMI settings, what can I change to fix this? I’ve never had this issue before.

Sometimes my AVR doesn’t even correctly find the Pi2’s HDMI port it’s plugged into since this update!

I tried the “unplugging and replugging it all after 10 minutes” and that DIDN’T work.

I’d appreciate ANY help on this topic.

I have to select the HDMI Input THREE TIMES for it to finally “stick” and the HDMI CEC control to fully return.

Log?
What version were you on before?

Edit: stop with caps lock and spamming my inbox on Reddit. Try and post in one place: you have also posted on the Pi forums

I’ll get the log tomorrow, I was on the version with Kodi 16 version 6?

What type of log do you want me to post?

What settings affect this issue I’m having?

Edit: Yea nobody was responding to the issue, so I tried to get help from different places, nothing wrong with that. I’m also not spamming you, I was giving feedback to your assistance.

I’m trying to work with you to fix this. But you’re not responding now, I just need to know WHICH LOG, please.

This thread is similar to my issue, how do I use this code with a Windows PC?

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

You can close this, I had to reformat the pi thanks to your help. I now can’t get the SMB to work! Great stuff.

Without any logs, we can’t help you.

Sorry.

I asked which logs, you didn’t respond!

I believe @actiona has linked you to the logs needed.
It’s literally 3 buttons on a remote.

I’m not sure you’re actually using OSMC; as the version you mentioned in another post isn’t an OSMC version number.