Pi2, RC6 Remote, Double-Pressing and rc.local issues

Hi!

So, I’ve got my Pi2 with the latest OSMC (just installed using the windows osmc installer to sd card) and I hooked up an RC6 clone remote from Rosewill (model RHRC-11001).

It seems to recognize, and on default osmc-remote-lircd config, seems to actually work with the very basic buttons.

Of course, if I go to rc6-mce-lircd it seems to probably have more functionality. But then it gets into double-pressing. Now, I’ve seen another discussion that had this…

And that seemed to work when I did a rmmod ir_rc6_decoder - I was able to use the standard rc6 profile or the lircd-full profile without double-presses.

That thread did mention that the rc6 profile was deprecated, so I am trying lircd-full.

Looking at that thread’s instructions, I tried inserting the rmmod command into /etc/rc.local - and when I reboot, the system says something along the lines of Failed to start rc.local Compatibility and asks that I check the service status with systemctl status rc-local.service. Of course, that’s no help at all.

If I manually do /etc/rc.local start, as long as the command in there is sudo rmmod…etc… then I can do it each time - but it doesn’t seem like I should need to do that.
I’ve tried sudo chmod +x /etc/rc.local and that applied but no change still failed to load.
Applied all updates to OSMC under My OSMC Updates,

What am I missing?

Is there a better way to get this remote working without killing that module every startup? Is there a better way to kill that module every startup?

You can blacklist that module to prevent it from loading:
http://linuxconfig.org/how-to-blacklist-a-module-on-ubuntu-debian-linux

Yeah, sadly tried it, doesn’t seem to change things.

I added it by going to modprobe.d and adding a blacklist-rc6.conf file like another site suggested about blacklist-xyz.conf - added the line:
blacklist ir_rc6_decoder
and left a newline afterwards, and saved.

Unfortunately, update-initramfs doesn’t exist in OSMC that I can tell, and after reboot, the ir_rc6_decoder module loads still.

EDIT: I fixed it by adding the install ir_rc6_decoder /bin/true line.

Woo hoo!

Would you mind typing up an idiot’s guide to what you did to solve this issue?

I’ve read a few threads on it and it’s all going completely over my head - I can’t follow what’s being done at all

Thanks

Certainly, I’ll try to write one up for another thread right away. :slightly_smiling:

Please check:

And let me know if you had further problems!