[Pi2 with lastest OSMC]can't use enter & back via a remote

remote model: Toshiba g83c0004d110
Everything goes well except the two most important keys(KEY_BACK & KEY_ENTER),
but in SSH, as I press the button like ENTER, it will reply with the right information:
000000037ff07bdd 00 KEY_ENTER ToshibaTB.conf
000000037ff07bdd 01 KEY_ENTER ToshibaTB.conf
I tried KEY_OK, KEY SELECT and KEY_OPEN, didn’t work at all but I can still see the right information in SSH(irw).
But when I watch video, it works, it displayed the home page.
I don’t know how to set the two keys. Should I need to add any content in the keyboard.xml(I’m not sure the file is related to the LIRC service)?
And where can I see the detailed definition of KEY_XXX?
Thanks :smile:

Here is the content

begin remote
  name              Toshiba
  bits                 16
  eps                  30
  aeps                100
  header       2667   889
  one           444   444
  zero          444   444
  pre_data_bits        21
  pre_data        0x37FF0
  gap              105000
  toggle_bit           22
  rc6_mask    0x100000000
      begin codes

        KEY_BACK      0x00007bdc
        KEY_ENTER     0x00007bdd
        KEY_RIGHT     0x00007bde
        KEY_LEFT      0x00007bdf
        KEY_DOWN      0x00007be0
        KEY_UP        0x00007be1

        KEY_REPLAY    0x00007be4
        KEY_SKIP      0x00007be5
        KEY_STOP      0x00007be6
        KEY_PAUSE     0x00007be7
        KEY_RECORD    0x00007be8
        KEY_PLAY      0x00007be9
        KEY_REWIND    0x00007bea
        KEY_FORWARD   0x00007beb

        KEY_CHANDOWN  0x00007bec
        KEY_CHANUP    0x00007bed
        KEY_VOLUMEDOWN       0x00007bee
        KEY_VOLUMEUP         0x00007bef

        KEY_MUTE      0x00007bf1
        KEY_VIDEO     0x00007bf2
        KEY_POWER     0x00007bf3

      end codes

end remote

You should use KEY_OK not KEY_ENTER.

KEY_BACK is fine. Have a look at /etc/lirc/osmc-remote-lircd.conf for an example of valid key names.

BTW are you running irw with a command line option ? Because it looks to me like you are running

irw /var/run/lirc/lircd-lirc0

Which shows the output from lircd, however we pipe the output of lircd through eventlircd, so the events should look similar to this:

osmc@osmc:~$ irw
9e 0 KEY_BACK linux-input-layer
9e 0 KEY_BACK_UP linux-input-layer

What customisations have you made to the remote configuration other than specifying a lircd.conf ? You shouldn’t need to customise keyboard.xml or remote.xml for most configurations.

Also please upload your logs with the log uploader.

I don’t know if this below is correct, but I still don’t know why and the two keys still don’t work.
Is that something wrong with hardware.conf?

root@osmc:/home/osmc# irw
69 0 KEY_LEFT devinput
69 0 KEY_LEFT_UP devinput
66 0 KEY_HOME devinput
66 0 KEY_HOME_UP devinput
66 0 KEY_HOME devinput
66 0 KEY_HOME_UP devinput
66 0 KEY_HOME devinput
66 0 KEY_HOME_UP devinput
66 0 KEY_HOME devinput
66 0 KEY_HOME_UP devinput
69 0 KEY_LEFT devinput
69 0 KEY_LEFT_UP devinput
67 0 KEY_UP devinput
67 0 KEY_UP_UP devinput
6a 0 KEY_RIGHT devinput
6a 0 KEY_RIGHT_UP devinput
9e 0 KEY_BACK devinput
9e 0 KEY_BACK_UP devinput
9e 0 KEY_BACK devinput
9e 0 KEY_BACK_UP devinput
9e 0 KEY_BACK devinput
9e 0 KEY_BACK_UP devinput
6c 0 KEY_DOWN devinput
6c 0 KEY_DOWN_UP devinput

I run irw again but the output in SSH still display with the *.conf file.

root@osmc:/home/osmc# irw
000000037ff07bdd 00 KEY_OK ToshibaTB.conf
000000037ff07be0 00 KEY_DOWN ToshibaTB.conf
000000037ff07be0 01 KEY_DOWN ToshibaTB.conf
000000037ff07bdf 00 KEY_LEFT ToshibaTB.conf
000000037ff07bdf 01 KEY_LEFT ToshibaTB.conf
000000037ff07bde 00 KEY_RIGHT ToshibaTB.conf
000000037ff07bde 01 KEY_RIGHT ToshibaTB.conf
000000037ff07be1 00 KEY_UP ToshibaTB.conf
000000037ff07be1 01 KEY_UP ToshibaTB.conf
000000037ff07be0 00 KEY_DOWN ToshibaTB.conf
000000037ff07be0 01 KEY_DOWN ToshibaTB.conf

Here is my hardware.conf file.

# /etc/lirc/hardware.conf
# Arguments which will be used when launching lircd

#Don't start lircmd even if there seems to be a good config file

#Don't start irexec, even if a good config file seems to exist.

#Try to load appropriate kernel modules

# Run "lircd --driver=help" for a list of supported drivers.

# usually /dev/lirc0 is the correct setting for systems using udev

# Default configuration files for your hardware if any

I just found other has the same problem with the two keys. Here is the URL:

I also found there is nothing in /home/osmc, should there(or the sub path) to have the Lircmap.xml?

I see your problem. You didn’t freshly install the RC did you - you tried to upgrade from Alpha 4 ?

If you had freshly installed the RC you would have linux-input-layer not devinput in the above log. (Also you would not have an /etc/lirc/hardware.conf file at all)

You have out of date versions of eventlircd and lircd (and other packages) that can only be solved by a fresh install of the RC, as upgrading from Alpha 4 is not possible.

Please post your debug logs using the log uploader so we can confirm you have an out of date eventlircd package.

OK,I am now uploading the log and I will try to install again.
Uploading maybe take a long time because of GFW…:frowning:
But I just change the KEY_BACK TO KEY_EXIT, this key works perfectly. And the KEY_OK still doesn’t work.
I have a question, as I reboot OSMC,the first command(irw) come back with “devinput”, but as I modify the *.conf file, stop then start lirc service, the message will come back with *.conf just like this:

root@osmc:~# irw
000000037ff07bdc 01 KEY_EXIT ToshibaTB.conf
000000037ff07bef 00 KEY_VOLUMEUP ToshibaTB.conf

Many thanks. :smile:


There is no point trying to debug the problem further on an Alpha 4 install as Alpha 4 is not supported and has no upgrade path to RC or later.

A lot of changes were made to remote support between Alpha 4 and RC including eventlircd source changes, udev rule changes (including changing devinput to linux-input-layer) and we started shipping our own custom compiled version of lircd with a patch to support event ID’s >255 instead of using the standard Debian lirc package.

Most likely KEY_BACK doesn’t work because of this missing lircd patch. If you install a fresh copy of the RC you should find that remote support works properly and KEY_OK and KEY_BACK both work.

If you still have problems with the RC please let us know.

I already uploaded the log(Alpha 4)
http://paste.osmc.io/ uhazakujor

I installed the RC and get update immediately, this time I copy my *.conf file and my remote works quite well.
Good work!!Thanks again!!
:sunny: :sunny: :sunny: :sunny: :sunny:


any new CMD for restar lirc ?
/etc/init.d/lirc restart doesn’t work

To restart lircd use

sudo systemctl restart lircd_helper@*

Also, if you use the remote option in OSMC settings to select or browse to a new lircd.conf file it will restart lirc for you.

Thank You Very Much :slight_smile: