Pi3 NFS Server

Hi all,

I searched the forum but couldn’t find any mention of the issue I’m having.

Recently started having issues with my Pi3 build and decided to reflash. Trying to set up my Pi’s NFS share and am having issues. Last time I did it I needed to load NFS via ‘sudo apt-get install nfs-kernal-server’ (as suggested in a previous thread) but now it seems like the default is nfs-common.

Tried to load my share to /etc/exports but doesn’t seem to be working. I will upload logs when I get a chance but just wanted to find out if anything had changed which I should be aware of.

Thanks in advance,

AFAIK, it’s still nfs-kernel-server.

In Debian stretch it’s now been properly brought under systemd.

1 Like

Nfs-common is the client part

1 Like
 sudo apt-get install nfs-kernel-server

would work better :sunglasses:

1 Like

So it seems my initial installation error was actually simply due to a typo (facepalm). Thanks for the input though guys, really appreciate it!!!

On trying to connect to an external VPN however, I ran into the same issue that prompted my reflash in the first place.

In order to get my VPN connection to actually work, I had to adjust the DNS servers in “etc/resolv.conf”. Replacing the OSMC defaults with Google’s DNS servers allowed me to connect. Any feedback on what the issue might have been? Think this changed in a recent build because I only had connection issues in the last few weeks or so.

The “defaults” in the /etc/resolv.conf are most likely provided from your DHCP server (read: router) via connman.

Unless you know which domainname (FQDN, e.g. supersecret.vpn.com) didn’t get resolved properly it’s hard to tell.
If you know the FQDN you could revert the changes to the resolv.conf and do a dig supersecret.vpn.com vs dig supersecret.vpn.com @ where is whatever resolver you’re currently using.

My bet’s on your DHCP propagated resolver (read: router :wink:) doing weird stuff and not the actual OSMC build.

First, AFAIK there’s no such thing as an OSMC default DNS resolver. It’ll be set to whatever you chose during the initial set-up (or whatever you amended it to later). It’s then used by connman to populate the file /etc/resolv.conf. If you want to change to Google DNS, you should ideally use connmanctl to change the default DNS resolver.

If you have installed resolvconf, that might have caused problems with /etc/resolv.conf, though that’s simply a guess. I recommend openresolv, rather than resolvconf.

1 Like

Hi Alphakilo. Seems you were spot on. My fibre router came preconfigured by the ISP and it turns out the weird DNS servers were inputted by them.

After a bit of googling, I managed to configure my Mikrotik router to use Google’s DNS servers and I can now connect to the VPN perfectly.

Thanks very much everyone, appreciate it!!

1 Like

FYI I wasn’t asked to configure a DNS during set up but it seems /etc/resolv gets populated with whatever DNS servers are provided by the router during each boot. Thanks again for the input

Yeah, perhaps it wasn’t worded as clearly as it might have been. If you had chosen DHCP during the initial set-up then you were in effect choosing the DNS resolver provided by the DHCP server - in this case your router.

I see that you have now updated your router’s DNS for Google DNS, which is the correct way to go about it.

1 Like

Oh ok, see what you meant. Thanks man!

Hey! Pssst!

From one routerOS user to another:
pi-hole is is the best local resolver for your home network.

Do not install Pi-hole on OSMC. Pi-hole installs things that interfere with OSMC.


Yeah noticed that, just had to try (while beeing remote, stupid me) and blew my pi3 setup with vpn-server. Not even responding to ping it anymore. Will try to rescue with local keyboard and local shell. Wish me luck.

Edit: Well vpn-server farked it up, reimaged the pi3 and made it to vpn server again. Installed pi-hole on pi2 insted, works okey, but there were issues with the installer on php-common, php-cgi. Had to install them manually.