Pi3 with 19.1 stuttering then freezing after few minutes of video playback

Hi all,
first of all, here is my uploaded log:
https://paste.osmc.tv/xevilirapo

I freshly installed 19.1 because I exchanged a corrupt microSD with an eMMC module (aka RaspiKey).
In the fresh installation, video playback always leads to a total freeze. Then OSMC is not reachable anymore. It displays as offline in YATSE app then. Sometimes, a few minutes later, it is visible as online again but super slow. I hardly managed to upload the above logfile.

Interestingly the TV playback does not lead to crashing/freezing. TV is played via TVHeadend, and SAT>IP server on my Synology NAS.

All video files are on my Synology NAS shared via NFS.

Everything ran smoothly on this device before I reinstalled the OS. What has changed? Before I still had KODI v18. And I had a corrupt microSD. Now: v19.1 and eMMC.

The log files are long and I would love to get a hint for what I need to look in it. I would like to find the right area in the log file at least ;-).
Thank you!

Have you tested your network with iperf3?

eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.178.40  netmask 255.255.255.0  broadcast 192.168.178.255
        ether b8:27:eb:a7:91:6a  txqueuelen 1000  (Ethernet)
        RX packets 2119812  bytes 2646893041 (2.4 GiB)
        RX errors 6  dropped 10781  overruns 0  frame 6
        TX packets 1021092  bytes 109844370 (104.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

That’s a good hint! I haven’t done it but will check now!

Log file for iperf3 in receiver mode (60 secs): https://paste.osmc.tv/ewakubacob.avrasm

Log file for iperf3 in sender mode (60 secs): https://paste.osmc.tv/amikosuzuz.avrasm

Everything seems to look normal, doesn’t it?

So this should be excluded as a root cause? What’s next? What is causing these packet drops?

“284 Mbits/sec” what is this? A Gigabit USB Adapter?

It is a Pi3. The Raspberry Pi 3 Model B+'s Gigabit Ethernet over USB 2.0 offers a maximum throughput of 300Mbps. It should be fast enough for a Pi3 to stream fullhd videos via NFS share and I assume this is not the root cause for the described problem. It might be another problem here but I doubt that this is the root cause.

I have a Netgear 48 port Gigabit switch: https://www.netgear.com/de/business/wired/switches/smart/gs748tv5/ ,
a professional Synology NAS RS3614xs as 19" rack with 12x 6 TB: https://global.download.synology.com/download/Document/Hardware/DataSheet/RackStation/14-year/RS3614xs/enu/Synology_RS3614xs_RS3614RPxs_Data_Sheet_enu.pdf .
And I have CAT7 wiring in the house, LAN everywhere.

I can easily reach 900 MBit/s on the same LAN socket when connecting a Windows 10 PC and copying a file from the NAS, see screenshot.

NAS.File.Transfer

Sure using that USB adapter also could explain the dropped packages.

Suggest to temporaliy try kernel (fstab or autofs) mounts and try to play the files via that to figure out if it is an issue with the Kodi NFS client.

I will try that now but I doubt that this is the root cause.

fstab: That means that I need to create an NFS share without any user/password protection, right? I would create a new one just for testing purposes and copy one video file there. Let’s see what will happen. I will report back here…

fzinken: Thank you for guiding me! Highly appreciated!

Kernel mounts offer the same options as Kodi NFS access.

Yes you are right, forget my comment with the password ;-). I configured the NFS share to give all users full rights fo the share, see screenshot.

I am trying to play a movie now…Let’s see…

fstab mounting did not work.

I followed a guide for that. The mount shows up in OSMC and also in the console but it is displayed as empty. I cannot see any files. It does not seem to be straightforward with Synology NAS, NFS, and fstab, as described here Using NFS with Synology .

I am giving up here for tonight.

Hi,

I use kernel nfs mounts with a synology using autofs and works great:

Thanks Tom.

autofs and fstab did not work. I was probably too stupid. I followed the guide and tried both, autofs and fstab. In both cases I could see the mounted shares in both environments, in SSH console with ls and in the file explorer of OSMC. However I couldn’t enter the folder and did not see the contents of the directory on the NAS.

Instead of wasting my time with it, I did the following:

  • Replace eMMC with another one (I bought three, and had one spare)
  • Complete reinstallation
  • Tried playback of my videos right after reinstallation (success!)
  • Now incrementally and carefully doing my customizations and tailoring and closely monitor the playback stability.

Root cause for the stuttering and freezing I had is still unknown. I still doubt that it was related to NFS.
Possibilities:

  • eMMC corrupt (unlikely)
  • any video add-on I had installed including dependencies
  • new Python scrapers I had tried (TVDB New)
  • TRAKT.TV programme add-on running in background