PI4 buffering

I have a PI4 (4GB) that start buffering with video playback. After a reboot it buffers straight away and if the PI has been on for a time it buffers after 2 to 10 min.
I have upgraded the power adapter to 3 AMP.
I have replaced the SD card
I have done a iperf speedtest.
I have removed all addon’s
All was good and made no differente to the buffering.
The CPU temp is 46 C.
Media comes from a NAS through NFS

The PI has run with Libre Elec for a good year without problems ( i went to OSMC because i wanted the same interface as on my Vero4K)

I made logs with van be found on

I hope someone has an idea where to look for a solution.

If really only the skin is what you are missing you always can install the OSMC skin on any Kodi installation including LibreElec.

What is the mediainfo of the file you are trying to play?
Does it happen with any video?

I don’t think it is only the skin. If the OS is the same you get more the same experience (and OSMC support the PI4 now).

I mostly play MKV and it happens with all those files.
When I play MP4 it doesn’t happen I think.

Media info :

Does no one experience this ?
Has any one a idea where to look for a solution ?

So I delivered logs, mediainfo, and excluded all external possibilities but no response.
I am a satisfied owner of multiple Vero’s but the support of the OSMC-team on the PI is almost nothing.

A very dissapointed OSMC user

Unfortunately we don’t develop Kodi for Raspberry PI

This would be best handled by Raspberry Pi themselves.

We can only provide support for the hardware and software that we develop. Raspberry Pi is handled on a best effort basis, free of charge and without warranty.

Instead - you should raise this with Raspberry Pi. We don’t have the access to Pi fundamentals to debug playback issues on this platform.

Our intention is to support it as best as we can.

Thanks for your understanding

1 Like

Are you sure that the CPU might not have a temperature problem after all?
The PI4 often has temperature problems. What kind of case do you use? Do you have heat sinks with a fan?
My PI4 showed a similar behavior with a standard case. After optimizing the housing, everything is much more stable.

Thanks for the reply’s.
I have a Flirc case witch dropped the cpu temp under the 46 degrades. So I don’t think it is the tempature.

I am thinking it is an auto negotiation problem on the gigabit interface. When I put a simpel 100Mb switch between the PI4 and the Gigabit Netgear all the buffering is gone.
I have done earlyer an extensive Iperf test but that didn’t show any problems.

So it looked like a cable problem but after repair I still experienced buffering.
I updated to the latest OSMC version and tested with a standard and a tuned installation.
So I still experience the buffering (after 3 to 5 minutes play) and went back to Libre elec witch has no buffering at all.

Someone any idea because I don’t have a clue anymore


Since you have a new install then you would need to provide new logs to get any meaningful feedback. I took a quick glance at your old logs and noticed that you adjusted the gpu memory allocation which should not be done on a RPi 4 as it does not work the same as older Rpi’s. Additionally I saw that there was a mpeg hw key added which makes me wonder if this was an old install that was put into or restored from an older RPi which would also be problematic. Clearly this key was not for this hardware since they are device specific and not available to purchase for this model. There was also refresh rate switching not enabled. There may also be some kind of compatibility issue with your network share and OSMC such that either configured the nfs share as a system mount may work better or setting it up using smb instead of nfs may get you better results.

Thanks for the response.

Let me explain by answering your questions .
The installs are the same only updated to the
latest OSMC version. I can make new logs but I don’t think the will bring more information.
Both installs are from scratch for the PI4 so no upgrades from early PI versions.
MPEG key was originaly bought for PI1 and I still had the key so put it in there , I believe MPEG is now license free but I thought it could do no harm.

I use the same NFS share for my Vero 4K and when I use the PI4 with Libre Elec ( also used it with OSMC on my PI1)

The GPU memory allocation is not standard and I have also tested with a standard installation.
The refresh rate I can look into, where can I find the setting ?

Again thanks for your response


That key only does something for the exact hardware that it was purchased for. That line shouldn’t cause any issue, but it also will not do anything positive. The MPEG 2 license is not free for the RPi 4, it is just not an option you are able to enable as it is assumed that the hardware is fast enough that hardware decoding is not necessary

I’m not exactly sure what you are trying to say here. On the RPi 4 GPU memory is dynamically allocated and although it is possible to increase the size of the preallocation a bit this serves no purpose and if you increase it too much it causes issues. The rules for GPU on earlier models do not apply to the RPi 4.

Your RPi 1 wouldn’t be running a current build of OSMC. Although it working normally with LE would be a good indicator that there is not a hardware issue in your network I don’t think the network stacks are identical between LE and OSMC. It is not uncommon for issues to pop up with Kodi paths that are rectified by using a system mount. The How-To section has a good writeup on how to setup a share with autofs and another on how you can path substitute to avoid having to rebuild your library.

Settings>Player>Videos>Adjust display refresh rate> On start/stop

So I did a complete clean fresh install .
No tweaks and no keys or anything.
I only configured MySQL and a fixed IP adress.
Nothing special and the first movie I played starts buffering after 30 sec.
I made new logs on https://paste.osmc.tv/heduxurowo

I am beginning to suspect hardware but I ruled out the wired ethernet, overheating (Flirc case) and a powerfull USB-C adapter. The Pi himself works perfectly with Libre Elec so I am out of options.

I think a hardware issue here is unlikely. I would do a quick gut check and put that file on a thumb drive and play it locally. Assuming that plays fine then make a system mount using [these instructions] then try playback from there using the file manager. If that is working correctly you can then use path substitution to redirect your paths to this system mount using [these instructions].

Alternatively, if using SMB is an option for your file server you could try adding a SMB source path and try playback using that. If that works you can just use a path substitution to redirect your NFS paths to SMB.

Just be aware in either case it is important that your sources remain the same as they were which hopefully corresponds exactly with any other devices that are sharing that MySQL database. You don’t want to scrape any sources with alternative paths as that will cause problems with your other clients. The path substation will allow paths to continue to be stored in the database using the nfs paths but be redirected on the fly to alternate paths.

The only other thing I could think of is playing around with your file server to change which version of nfs it is using.

So I put the file on a thumbdrive and the results were confusing because the buffering notification came but after forward or rewind actions and onscreen menu actions.
I tried the autofs option but couldn’t get that working direct so I need to put some more work in to that.

What maybe new info is that the buffering notification always goes with a freeze of the video (not the audio) and it never comes back from that (I always have to stop the playback). I don’t know if this helps but I am at a lose because I all works fine on the vero 4k (so the nfs server side should be oke) and with LE on the PI4 it also works fine

Is this issue only when your using ff and rw? That is known to be not working correctly. If you use skip steps instead (direction keys during playback) is there still an issue?

8 posts were split to a new topic: Problems with buffering while fast forarding

I grabbed of copy of that same Legacies file your playing in your logs and tried it on a RPi 4’s running both current stable and the Bullseye test build. Not only did they both playback flawlessly but to my surprise ff/rw actually worked as well without any glitches.

I think I would try it again using a thumb drive on a completely fresh install. If an option you might also try a different SD card and/or plugging the OSMC install SD into the RPi that is currently running LE without issue just to rule out hardware.

1 Like