Pi4 OSMC USB TV Dongle not showing Sony Tuners

I’m trying to configure a new OSMC USB TV Dongle from you and am having problems reliably getting the Sony tuners to show up - only the Realtek is shown.

When I first plugged the device in (using a powered USB 3 hub) I did see the Sony tuner and used it successfully. However, after (cold) rebooting the Sony tuners had disappeared, rendering the device useless.

I tried including plugging into the Pi4 directly and this seemed to work initially. However, after rebooting the Sony tuners once again disappeared. I’ve tried leaving it to ‘cool down’ to see if it’s a heating problem but this made no difference.

I don’t especially want to reinstall as I’ve been using the device for some time with another USB tuner (August TV210), and have many programs recorded and timers set up.

I was trying out an OSMC tuner to see if it helps reduce data errors in recording (These show up as green pixelation or smeared coloured bands from the bottom of the screen). Some recordings are totally unwatchable. This does not go down well in the household when it happens at the crucial moment…

I’ve uploaded a log in the hope that this may indicate my issue - https://paste.osmc.tv/jotadazixe




I’ve seen some issues where the tuners aren’t detected on a warm boot, but not a cold boot, unless there’s an issue with the devices not getting enough power.

Your logs are showing the Sony tuner as detected, perhaps you need to clear the TV tuner cache iin TVHeadend.

Nov 06 12:00:50 osmc-Nigel kernel: dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
Nov 06 12:00:50 osmc-Nigel kernel: usb 1-1.1: DVB: registering adapter 0 frontend 1 (Sony CXD2837ER DVB-T/T2/C demodulator)...
Nov 06 12:00:50 osmc-Nigel kernel: dvbdev: dvb_create_media_entity: media entity 'Sony CXD2837ER DVB-T/T2/C demodulator' registered.```

I think what Sam means is:
rm ~/.hts/tvheadend/input/linuxdvb/adapters/*
followed by setting up the tuners in the TVH webui. Do not enable the realtek tuner.

I’ve tried quite a few TV tuners over the years. For what it’s worth my experience has showed the best for sensitivity / low errors are (in order):

  1. Silicondust HDHomeRun Connect (network based)
  2. PCTV 292e USB
  3. Xbox Tuner USB (Panasonic chip)
  4. OSMC Tuner USB

Did you try them all on the same Linux platform though?

The OSMC tuner (older versions) are based on the same Panasonic chip found in the Xbox model, so I’d be surprised if there was any variation unless you were testing on different platforms…

For the records, yesterday I have do a clean reinstall of osmc. To restore my data I have moved /home/osmc between the installations.

No change, let night my vero hung up.

Thanks sam,grahamh, clearing the cache in the way you describe seemed to enable the Sony tuners once more. I now have it in the powered hub once more. I’ve tried a warm and cold boot and the Sony tuner is still visible and working.

I’ve just enabled the Sony DVB-T tuner, not the Realtek, as suggested. I’ve also not enabled the the Sony DVB-C tuner which I presume is redundant with this dongle.

Thanks for the help.


This tuner look interesting. Are the 2/4 tuners recognised in the same way under “TV Adapers” by Tvheadend server?

Also would the type of data errors I’m seeing (blocks of green and smeared coloured bars at the bottom of the image) be connected with sensitivity, or could they be connected with other issues on the Pi or NAS interface (which is cabled gigabit network to Synology NAS)?


I’ve found flashes of green blocks and mosaicing to be indicative of poor signal strength, but that’s using a Vero, not a Pi4. I also had video corruption immediately after installing Matrix/kernel 4.9 on that Vero but it’s cleared now with later updates. My two DVB dongles and HDD all go through the same USB port which I suspect had something to do with it. Pi4 is said to separate ethernet fron USB so that’s unlikely to be a factor.

The only measure I’ve seen for signal strength in on the “Status” tab of the Tvheadend web ui. When I set the tuner to watch BBC2 HD live (not recording) this reads between SNR 29.6 - 32.1dD Signal Strength 25.2 - 27.4 dBm (UK Crystal Palace).

However, I’ve no idea if these are good or bad, or what I should be aiming for to achieve reliable reception. I am seeing the occasional breakup/pixelation with these values, especially as Signal Strength heads below 26dBm.

I’m not sure exactly what the Continuity Errors are, but they seem to increase in line errors in the stream (freezing or pixelation).

I currently have a loft aerial with an amplifier in the loft to distribute around the house, then another near the Pi to split out to the TV, radio and USB tuners.

Exactly what I have, with no line-of-sight to my transmitter, except I don’t have VHF. Aerial and all kit and cables from the excellent ATV in Sheffield. Signal strength is a mystery and varies in presentation between different dongles but if you do get mosaicing when the signal strength apparently dips then you might check through the aerial system. FWIW, my Sony tuner on BBC2 SD is currently showing s/n 40dB and signal strength 7dB - 17dB and I am getting the odd glitch and ‘continuity errors’. Must be the weather.

Update: now watching TV on the same device that tvh is running on - it’s fine. Earlier I was streaming to another device through WiFi. So that mosaicing must be a network issue here.

As an aside – I’ve seen that the tuner is behaving better on Debian Bullseye on an x64 machine here; which suggests that there might be some upstream kernel improvements that we should merge in to our 4K+ kernel.



Admittedly it was a couple of years ago now but it was the OSMC tuner with the Realtek and Sony tuners. My testing was using the Sony chip exclusively.

I tried it on both Vero 4k and RPI 3B (at different times) using the same aerial port.

I didn’t raise as an issue at the time as I had multiple tuners available and for the money I was curious to see if the OSMC tuner was better than others I was trying out.

As long as it’s installed on the same network they will be automatically identified by tvheadend and appear as separate adapters.

I believe the green smearing is a sign of missing data or corrupt data. I’d be surprised if it is the NAS side. Most likely the frontend of the tuner.

From my testing the hdhomerun devices are the closest to the receive sensitivity of a normal TV. If your TV plays channels fine out of an aerial socket then the hdhomerun will be the best next thing in my experience. I’ve yet to come across a USB TV tuner device that matches a TV’s reception.


A lot has changed in the last couple of years…