Picture freeze and network is lost during playback

Hello there

I have a Raspberry Pi 2 connected to the internet via a wifi Apple Airport (the Airport is providing internet via Ethernet).
I have done a fresh install of OSMC via NOOB and updated it. My video content is on a NAS so I found the source and played a movie.

it works for a few minutes, then the picture stops, one CPU goes to 100% and usually I lose network connectivity (I cannot ping the Pi anymore from a PC and the Android remote loses communication).

It was happening with a Pi3 and I tried my Pi2 to check whether it was HW or SW related.

These are BD ISO’s so the bandwidth is up tp 40Mbit/s not sure if this is the behaviour I should expect if the buffer does not get replenished in time.

As suggested, I have enabled the debugging, rebooted and restarted a playback, which crashed a few minutes later.

I do not have anything connected to the Pi but a USB mouse. I did not install anything, just the remote on my mobile.

Logs can be found here http://paste.osmc.io/ewotudipab

The playback stopped at 17.38. Kodi eventually quit the playback page and went back to the movie page at 17.42. I could not upload the logs (no internet access anymore) so I rebooted the Pi at 17.44.

Can anybody help please?


I have an update.

I’ve tried a different PSU and an older version of OSMC. Same result. However the older version seems more diligent in telling me what was wrong and came up with a network timeout error.

Wiring the Pi with a (long) cable seems to work.

I do not really understand, I left the Pi on for hours and I could ping it from my main PC all the time. How come the connection disappears only when it gets used? I kind of doubt it’s a network issue, more the way the Pi behaves to some network instabilities. Any ideas?

Test your network over a longer period with iperf3

thanks for your help.
iperf3 is giving me silly values but anyway the network drops after a while. I tried iperf3 on my Windows 7 laptop and indeed the network drops after a while.
Definitely a network issue. Thanks again!