Picture slideshow does not play videos within folders

Hello,

I have OSMC running with the latest update (2017-03-22). I use the Picture slideshow to play pictures and videos in a folder. Pre-Kodi-17 it dit work, since then videos only play sound but have no picture.

Hardware is Raspberry PI 1 and 2

Compared to a Kodi-Installation on a Win7 PC where that works nicely. Also during the Beta-Fix-Logs of Kodi-17 this seemed to be one issue.

Best regards

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I have got a similar problem. MOV files in Pictures folder stopped playing recently. They fail to play as a part of a slideshow and as single files. Only audio and black screen present. Picture files render fine. The same MOV files play fine when places in Videos folder.

Here is a log: I first unsuccessfully try to start a MOV file in Pictures folder (rather, in a subfolder of a Pictures folder); then I successfully start the same file in Videos folder.

http://paste.osmc.io/jojejodiwu

Best regards,
Vladimir

Hello
ok, here is the log: http://paste.osmc.io/tatatehihe.hs

Steps I did:
Pictures

  • browse to folder with video and files
  • select “start slideshow” on a picture before the video
  • let it run (was quite slow, but the video did not show a picture, so i continued)
  • exit slideshow with stop and exit
  • play video directly (did work)
  • play another video (did work)
  • select “start slideshow” on a picture before the video
    –> same thing again: no video picture, just the sound.

videos are mkv with h264, but mp4 and mov show the same effect

complete setup:
rPi2 -> receiver -> tv
there are no peripherals connected to the pi. only power, ethernet and hdmi

this is 100% reproducable.

edit:
just found out, that the problem can be produced by selecting “start slideshow here” on a video file directly in the pictures browser.
It does not need to start with a picture and be followed by a video…

I have exactly the same problem. Kodi 16 played the videos in the slideshow, now I installed a new Raspberry with Kodi 17 and the pictures are shown, but for videos only a blank screen is shown.
The mov-files are the same wich worked in Kodi 16…

Found the fix log of the Beta, where this also appeared. I do not know, which pull is actually the matching one (looked through all of them, but did not find one). Also: maybe we have a different bug here.

Same problem here on Pi3, while no issues with video playback during picture slideshow on Win10 version. It has always worked fine for me on the Pi1/3, until the 17.x upgrade.
I’m a little disappointed with this "up"grade, since it does not bring me any new features, and creates instabilities like loosing skin settings after reboot and more. Hopefully OSMC will become more stable again in near future, since I still really like the OSMC Kodi version.

I have the same problem. It was there with Pi / 1 and now with Pi /3.
I have latest version, June 2017.
I have combine in two videos and photos. When the slide show plays a video I get audio but no picture. If I press the back button on TV remote I can see file list and video is playing as the background of the menu.

Is there a way I can help with logs and other tests? How can I collect this data?

Thank you,

Bruno

Probably the same problem as this

Should be addressed with Kodi.

The kodi installation on my pc does it fine. since 17.0 and newer …

Is there any new information regarding this? I am also looking to play slideshows and videos in a loop with a headless Raspberry Pi that gets the source files from a network drive with cloud interface?

It’s a Kodi issue. How was it addressed by them? The link to their discussion is above.

If I am interpreting the earlier comments correctly, it seems that there is no issue on a pc, but only with the Pi.

I guess if Kodi says so… This issue is with Kodi alone and has nothing to do with OSMC.

@nls I just reported this problem. I have no clue if it is a Kodi issue or not. Unfortunately there is no kodi bug linked. Someone would have to experiment with either newer v18 builds and see if its solved on a pi or test other kodi-raspberry distributions.

I am missing this feature too, but have no time now to do those experiments.

With the full release of Kodi 18 with OSMC getting closer, has this feature of being able to play videos with slideshows been verified?

I am updating my earlier post. I installed the Kodi 18.0-RC2 release on the 2018.10-1 release of OSMC, and the problem is still there - slides are displayed properly, and the moment it goes to the video, the screen goes blank, but the audio can be heard. We seem to be caught in-between, with Kodi developers saying that it is a Raspberry Pi issue, and the OSMC developers saying it is a Kodi issue, how can this be resolved?

OSMC doesn’t necessarily equal Raspberry Pi so both could be right.

OSMC is saying this it a Kodi issue and the Kodi people are saying it’s a limitation of the Raspberry Pi hardware.

I don’t think that it is a Raspberry Pi hardware limitation, because this feature worked with earlier versions of Kodi. But Kodi 17 - rc3/rc4: problem in slideshow: playback of videos is stumbling seems to indicate that it is, very confusing! Does somebody from the Pi development group need to get involved?