Picture slideshow fails

Is anyone having similar issues with doing a picture slideshow. I don’t use it often, but it appears that for quite some time, when I try to do a slideshow of the pictures I have stored on my NAS the system freezes and reboots.
image
It seems to do this when the first slide is supposed to switch to the second.
I have Kodi running on my android TV directly as well and tried the same without any issues.
My Vero 2 is connected through cable and my TV is using Wifi.
Any idea where I should start looking first?

Provide debug enabled logs

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

While it might be a decoding problem

I use the slideshow quite a lot and it seems to work just fine for me.

I will review this and post the required information as soon as I get it. Thanks!

OK I tried replicating the issue tonight with the same images and wasn’t able to do so when debugging was enabled and after disabling again it still worked fine. I just installed the April update, so maybe something in there has fixed the issue… If so great, but I will keep an eye out to see if it happens again…