Pictures in 4K

Hello all, I went through some posts and it seems, that it is still impossible to watch pictures in true 4K resolution, which is a big drawback for me. Can anyone confirm this and possibly also give an outlook when this will be possible?

Apart from that I have two more problems: Photos that are not in 16:9 format are zoomed, probably to avoid black bars. I want to see of course my original photo. Panning and Zooming are deactivated.

When opening a directory with photos on the NAS it takes many, many seconds until the content is displayed, sometimes there is a scrollbar “updating library”. But this scrollbar comes again when I open the same folder a second time. So smooth navigation is not possible.

Regards, Georg

Following up on the Kodi threads that have been linked in similar threads here will likely provide the best info. This is a Kodi limitation and not specific to OSMC.

What skin are you using? I cannot reproduce this and i’m not aware of a setting that allows for anything other than viewing the entire picture by default.

They are not disabled, the zoom is just not mapped by default. If your using the OSMC remote there will be an update in the near future which will allow you to zoom in/out with a long-press of the up/down, and view the entire image with a long-press of the OK button. When you are zoomed in a short-press of the direction keys pans. In the interim, or if your using a different controller, you can install the ‘keymap editor’ add-on and use that to map buttons to these functions. You will be limited to just short-press actions.

Have you tried enabling thumbnail generation?
https://kodi.wiki/view/Settings/Media/Pictures#Automatically_generate_thumbnails

As soon as you start a slideshow, the pictures are scaled and cut off to fit the 16:9 screen. If you watch them without a slideshow they’re not scaled. Standard Kodi behaviour…

I get the full image with black bars on both RPi w/ OSMC and Kodi on my PC weather i’m viewing a single image in photos, slideshow, or file manager. It is the same if the Ken Burns effect is on or off. It is the same on Estuary and OSMC skins on my RPi, and both skins on my PC. If this is standard Kodi behavior there should be some setting that I flipped somewhere for this feature I don’t use that I can’t seem to find.

There sould be then (although I haven’t come across any yet myself) as our skin doesn’t have any special adjustments in place for the slideshow. For me, images with horizontal orientation are scaled down to 16:9 aspect ratio while cutting off information as soon as the slideshow is enabled.

Check out this thread, seems you can disable it with a setting in avancedsettings.xml
https://forum.kodi.tv/showthread.php?tid=324688&pid=2733650#pid2733650

2 Likes

This is such an odd thing. After reading that I checked my test pictures and they were lower resolution than what they said were affected in that thread. I then pulled over larger images but still couldn’t reproduce. I read that thread again and noticed aspect ratio was mentioned. I cropped one of my images to 3:2 aspect ratio (was 4:3) and it finally displayed zoomed in and cropped off in the way described. I have verified that the solution provided in that link does stop this behavior.

ssh into your Vero and type

nano ~/.kodi/userdata/advancedsettings.xml

Then put the following text in the file

<advancedsettings>
	<slideshow>
	<blackbarcompensation>0</blackbarcompensation>
	</slideshow>
</advancedsettings>

then press ctrl-x, then y, then enter, to save the file and close the text editor. Reboot Kodi to allow the setting to take effect.

1 Like

Thank you all for your help, the black bars are now there and I can see the whole image, both in browser and slideshow.

I only wanted to refer to the panning and zooming effect during the Slideshow. With the modified advancedsettings.xml this is fine now.

Unfortunately this has no effect. It is very strange. Even if I try to open a folder several times up to 20 seconds really nothing happens, than for a short time the circle is going round, then if I’m for the first time in this folder the update library bar appears. If I go to the same location via videos instead of pictures the behavior is completly normal.

That’s to be expected as there no library for photos. Therefore, each folder will be “scraped” again each time it’s opened.

It was a shot in the dark. From what I understand the speed of the thumbnails displaying in Kodi is a combination of how long it takes to generate thumbnails and how long it takes to load all thumbnails for the given view. Apparently Kodi is currently coded such that it must process all images and not just the ones in the immediate field of view. I think this setting is meant to deal with the former, and there is not much of a solution to the latter (except maybe moving the pictures and cache to a SSD or dividing your images in subfolders). Just out of curiosity how many images are in this folder your trying to view?

The number of photos in the folders is different, but I don’t think that this is the real reason. The folder I’ve tested with minimum amount of photos has 65 files, the one with the most has 350 files. On both there was a huge delay. And it is really the case, that nothing happens during this delay, you think you haven’t pressed the button. I assume, that this is not a general kodi problem, on my TV the app SPMC is running, I think also a kind of kodi, and with this app there is no delay opening the folders.

Which skin are you using? I’m a bit stuck here as i’m back to an issue that I can’t reproduce. I loaded up a folder on my network with 650 png files that averaged about 2MB each. With the OSMC skin on first entry into that folder I got an animated wait indicator (so obvious it was working) for 13 seconds. I had enabled to thumbnail option in settings so I assume this was part of the extended delay. When I back out of that folder and go back it i get an animated wait indicator for exactly two seconds. I rebooted and tried it again. First entry was five seconds, after that any time I go to another folder and come back it is two seconds.

The skin is OSMC too, the jpg files have a size of about 6 Mb each. Once the animated indicator is coming there is only a small amount of time to wait, problem is the long time at the beginning. My network setup is SMB.

I’m not sure what to tell you. I’m using smb as well just to a Win10 PC using Kodi smb:// paths. The time on the very first entry to that folder for me before the animated indicator comes up is less than a second. The 13 seconds was from me clicking on the folder to when the list of files appeared and were browsable. I dug through My thumbnail folder and verified it generated thumbnails for all images in this folder and cached them at the size set in advancedsettings.xml. I then took the same folder and put it over on a SSD on that same machine. The very first time I went to the folder it only tooK seven seconds. Every other entry into that folder took the same two seconds as when I was grabbing it from spinning rust. This seemed to confirm that when generating thumbnails is enabled it pulls from the cache and not the source. I then went on my Windows box and pulled up the network monitor and only saw a small blip when I first entered the folder. Scrolling up and down through the image list produced no activity as the thumbnails being displayed were coming from the local cache on my RPi. I only got any activity when I displayed the images full screen as it should do.

Thank you very much for your activities! Is it perhaps possible to activate some kind of logging to find the root cause for this? Otherwise I will live with the behavior.

Kodi debug logs don’t really show anything useful for this particular issue. Just out of curiosity you don’t happen to have your GUI set to a 4k resolution do you?

No, it is 1080p. Perhaps if I have time I will make a factory reset and test again, I have been in so many menus that I cannot remember the original settings.