Pivumeter on OSMC

I try to install Pimoroni pivumeter (with Scroll pHat HD) on OSMC.
The setup of the Scroll pHat HD is ok, I can make it work with the exemple scripts.
But when I install pivumeter and I reboot, OSMC gives me the sad smiley. If I remove the .asoundrc file created by the pivumeter installer, OSMC is booting.

I Use a HifiBerry Dac Plus Pro

Here is the .asoundrc:

pcm.!default {
type plug
slave.pcm {
type meter
slave.pcm “softvol”
scopes.0 pivumeter

ctl.!default {
type hw
card 0

pcm.dmixer {
type dmix
ipc_key 1024
ipc_perm 0666
slave.pcm ‘hw:0,0’
slave {
period_time 0
period_size 1024
buffer_size 8192
bindings {
0 0
1 1

ctl.dmixer {
type hw
card 0

pcm.softvol {
type softvol
slave.pcm “dmixer”
control {
name “PCM”
card 0

pcm_scope.pivumeter {
type pivumeter
decay_ms 500
peak_ms 400
brightness 128
output_device scroll-phat-hd

pcm_scope_type.pivumeter {
lib /usr/local/lib/libpivumeter.so

pcm.pivumeter {
type meter
slave.pcm ‘hw:0,0’
scopes.0 pivumeter

pcm.dsp0 pivumeter


You need to post the logs

Don’t know much about this, but try asking Pimoroni and pointing them to this thread.

They’re very helpful chaps and a few of them use OSMC regularly. I’m sure they can help.

Logs will also help.


I wonder if kodi is getting confused about which Alsa sound card to use ?

I just installed pivumeter on an osmc Pi without a dac and osmc still works.

I’ll add a dac and report back cos I’m interested in getting this working with hyperionD

I dug out my old pi1 with a cheap Ebay 5102 dac.

I had to build wiringpi from source and then installed pivumeter.

Copied the sample asound.conf to /etc and rebooted.

Osmc still works fine

did you install wiringpi ? It’s a pre requisite but apt-get couldn’t find it so I built it from source.

Note, I don’t have any supported hardware so I don’t know if the vumeter actually works !

Thanks for your answers.

WiringPi is installed.

I had a look at the log. The issue was with i2c. I enabled i2c and OSMC booted ok. But the pivumeter didn’t worked.

I went to OSMC settings, system, audio to look at the sound card used. There wasn’t the ALSA: Default (snd_rpi_hifiberry_dacplus Analog) anymore. Only HDMI and analog.

If I delet .asoundrc and reboot, I can find the ALSA device.

I have to investigate with the Alsa conf…

Someone asked about this on Twitter and I put them in Pimoroni’s direction, but we haven’t heard anything from them just yet.