Play 4K Quicktime MPEG4 from DJI drone?


i have a video made from a DJI drone, Format is .MOV (MPEG4 Quicktime, 4K resolution), and I would understand if the raspi was too slow to decode it, but on my Raspi2 with OSMC, that video plays totally crippled, i.e. only color artefacts, and no real content is visible. Is that normal? How can it be playerd back?

Well first you would need to understand the exact codec of the file. Suggest to install mediainfo and run it against your file. Then post the output here.
But despite of the codec it is quite challenging for a PI2 to play any such file without hardware decoding.

Thanks, I am not sure if medianinfo gets the resolution right, but here is what it shows:

Complete name                            : DJI_0002.MOV
Format                                   : MPEG-4
Format profile                           : QuickTime
Codec ID                                 : qt   2014.02 (qt  )
File size                                : 1.15 GiB
Duration                                 : 2 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 60.0 Mb/s
Encoded date                             : UTC 2016-06-30 11:45:34
Tagged date                              : UTC 2016-06-30 11:45:34

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 1 frame
Format settings, GOP                     : M=1, N=8
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 2 min
Bit rate mode                            : Variable
Bit rate                                 : 60.0 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.241
Stream size                              : 1.15 GiB (100%)
Title                                    : DJI.AVC
Language                                 : English
Encoded date                             : UTC 2016-06-30 11:45:34
Tagged date                              : UTC 2016-06-30 11:45:34
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

The video is actually H.264 (aka AVC) which means it gets hardware decoded.
But the hardware decoder won’t decode 3840x2160 video (1920x1080 is the limit) so it appears corrupted.

Thanks, I thought it should at least be possible to downscale that video, at least my PC does that.

If you can lower the output resolution from the drone, you should do that.

Of course I could do that, but I want to have the highres videos, and all of my devices can play them, only OSMC seems unable to downscale them.

You cannot downscale video like that. You need to be able to decode them. Your PC is not downscaling them, it is playing them at their native resolution. You may not have a 4K monitor, but your PC is still decoding the 4K video files.

The process of downscaling would require transcoding and decoding. Running these two processes at once would stress the RIL components even further, ignoring the fact that the VideoCore IV cannot handle these resolutions in real-time for either process.

Which devices play these videos, and over which protocol? I wonder if your device is serving a lower resolution version to other devices.

If you want to avoid the corruption, make sure omxplayer and MMAL are disabled in video/acceleration settings.
Your video will probably play correctly now, but don’t expect more than a few frames per second.