Play DVD from remote PC

I’m running kodi 18.3 on a raspberry 3. I want to play music / videos from a remote DVD which is in a PC on my home network. Is that possible ?

You can enable file sharing on an optical drive in Windows and then add that share to Kodi but i’m not sure what kind of performance your going to get out of that setup.

Thanks for the quick answer. Can you please tell me exactly what you are meaning. I already opened the remote DVD device for sharing but I don’t know how to add this share to kodi.

You would add it like any other share. If your using SMB and your PC is using for its ip address (as an example) and you named your DVD share “D” then you would go in kodi video>files>+Add videos and then click on “none” and enter the path “smb://”.

It is worth adding that this sharing of a physical disk is very non-standard. Most people would use something like makemkv to make backups of their movies and music would be ripped with a whole host of different programs in whatever format that suits their preference. Kodi has been built around having a library of files that are accessible at the same time and really works best that way.

Once again thank you for your answer, but unfortunatelly it does not work. I get the answer “operation not permitted”.
And yes at my windows PC the support for SMB 1.0 is enabled.

Did you also enable it in Kodi? Also are you trying guest access or with proper user/password?

If your using Windows 10 you may have to go to (in Windows) settings>network & internet>status>staring options>all networks>password protected sharing> (Turn off password protected sharing)

If you do actually have SMB 1 setup in Windows then you may be able to browse for the share instead of manually adding. Using SMB 1 is not recommended for security reasons just as a FYI but it will not cause any issues with OSMC or Kodi if you do.

In Kodi you may have to manually make a file in your .kodi/userdata folder called “passwords.xml” and inside of that you would put…

        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://User%20Name:password@</to>

With your info in place of the above. If you have any spaces they would get replaced with “%20”. A reboot is necessary after you make this file.

I just tested this with a music CD and that does not work as the “files” that show on a music CD are not actual files but more like placeholders. I’m having trouble finding a DVD to test but that should not have the same issue as a CD would.

EDIT: I couldn’t find an actual movie but I put in the DVD that came with my Tool Salival Box Set and the Video played without issue from that.

1 Like

It should probably be mentioned that if you plug a external USB DVD drive directly to your Pi it ‘should’ work with most media including audio CD’s. If the drive uses an excessive amount of power it may have to be run through a Powered Hub.

To answer your question:
I use guest account - other PCs in my network see the enabled drive but not kodi on raspberry. Browsing does not see the enabled device, even my Workgroup is not seen. Searching with smb:// delivers an error message: “Connection timed out”


  1. for Brwosing and Guest Access you would need to enable SMB1 in Kodi
  2. Guest Access is known to be problematic
  1. I did enable SMB1 in Kodi
  2. OK, what can I do ?

Use a user account and give it access to the share.

I think you can get that error if the drive does not respond fast enough or there is no disk in the drive. You might start off with just the ip as you can edit it later to add the “d” once you get it working.

How Win10 computers are able to authenticate with each other is different than what is required for ‘other’ OS’s. If you tried to connect a Win7 PC to your share it would have the same issue. You need to use an actual username/password from any account on the machine your sharing from (It does not matter if this account is logged in, just that it exists). Guest is a problem as Windows puts restrictions on that name. If you don’t want to use your main account credentials then make another user account to use for this (you don’t have to ever log into this account for this to work). In my setup I just tested this with a had to make the passwords.xml file and reboot kodi before I could connect. Turning off password protected sharing was also necessary.