Play home videos from local NAS

Hello, sorry I am a newbie here used to Windows (sorry for that). A have Vero V mostly used with an add on to play vidoes from a web server and it works 100% fine.
BUT, I would like to use the intenal player also to play my (mostly) home videos stored on local NAS. Is there a simple way to just map the folder and play the videos from the folder? I mean I googled a lot about the recomended mounting of nfs, finetuning the setting both on NAS and the client and after a few days succeeded in +/- mounting it. But then it ended up on the unexpected requirements create a library in Kodi with required naming conventions of all the videos which I am not able to do. So can I somehow just go to a mapped videofolder and play a selected file (as in windows)? The videos are mostly UHDs in H.264 but I do not seem to make them play (or even apper). Thank you

You don’t need to use the library mode - that’s only if you want metadata like descriptions and artwork

For home movies, or any content that doesn’t have entries in scrapers you have the option to either not use a library, or else manually make files that contain the metadata that would allow it to show up in the library in the movie or TV sections.

The easy path is to just add the source but don’t configure the content type/configure the scraper. When you want to watch something you would just go to videos>files>[your source] and play from there. If you want a bit more direct path and/or setup a few different top level folders for easy access you can navigate to the folder you want in videos>files and then context menu>add to favorites which will put that location in the favorites top level menu (assuming you have your skin configured to show that menu item). Some skins will also let you configure a top level menu item for that path as well but how you would go about doing that is specific to the skin your using.

If you want this content added to the regular library you would need to generate nfo files. If this is what you want I’d recommend using a media manager app such as Tiny Media Manager to allow a relatively painless process. With TMM you would install it on a PC and add you home movie folder to its preferences and have it scan and then manually add in descriptions and any artwork you want. This will make files next to you home movies that Kodi will use to populate the library. In Kodi you would set content on the source to the local information only scraper.

Thank you so much for your answers. Actually the library is what I do not want to create. I like my own folders. The problem is taht most of the videos in the mapped folder do not play, though I do see them. Some exceptions do play but mostly I can only see the file and if I click it I get just a loading circle and after a while some error message. (of course I can play the same files allright when accesed from a comp with Wins, so the files are not corrupted). Thus, I thought I need to do some more settings in Kodi even after I correctly map the folder. Or the problem is somwhere on the way from NAS to my VeroV…

Logs will probably help :wink:

Thanks all. I tried to reinstal Kodi on OSMC and after that succeeded in manual connection of my video folder. As per the advice I did not select it is “films” and stopped serching the library and it really showed all files just in folders and +/- played them as you said. However, with a lot of lags, corrupted sound etc. for all HD videos. As I read in many places, it happens with high bitrate videos, so as per the advice I tried to mount the drive and did not succeed…

I grabbed the log here:
I did all setting in my Synology NAS as per KODI Wiki:

I tried to mount the NFS folder as per the guide: Configuring fstab based NFS share mounts
but still I get: -bash: cd: /mnt/VideoNFS: Permission denied
Please any tips what I am doing wrong?

You spelled automount wrong…

====================== fstab =================== qiE9Dtax  /mnt/VideoNFS     nfs   noauto,x-systemd.aoutomount 0 0

---------------------- fstab END --------------- qiE9Dtax

As for the videos not playing you would need to supply a debug kodi.log and/or mediainfo for us to to even comment on that as we don’t know what codec’s your trying and failing to play.

Thank you! You help me a lot and I am learning… In the meanwhile I managed to mount nfs using another guide here (autofs method). The access denied was there anyway but I plaid with the NAS setting so long I finally got a working setup.
I used the mounted nfs folder from the root mnt/ as you adviced, did not set its video and exluded it from the library. So now I see the folder just as I wanted with all the files.
But still the mp4 UHD videos do not play well. Now I do not get any error so I am not sure if a log would help. But I attach the media info.

Complete name : V:/Video Export/Anežka hotové/Aný_5m_3840x2160.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 10.6 GiB
Duration : 16 min 27 s
Overall bit rate mode : Variable
Overall bit rate : 92.2 Mb/s
Writing application : Lavf60.3.100

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.2
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 4 frames
Format settings, GOP : M=4, N=50
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 16 min 27 s
Bit rate mode : Variable
Bit rate : 92.1 Mb/s
Maximum bit rate : 120 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 50.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.222
Stream size : 10.6 GiB (100%)
Language : English
Codec configuration box : avcC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 16 min 27 s
Source duration : 16 min 27 s
Bit rate mode : Constant
Bit rate : 129 kb/s
Channel(s) : 6 channels
Channel layout : C L R Ls Rs LFE
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 15.1 MiB (0%)
Source stream size : 15.1 MiB (0%)
Language : English
Default : Yes
Alternate group : 1

I don’t think the Vero’s support hardware decoding of h.264/AVC at 4K resolutions and they lack the rather sustancial CPU power that would be needed to do such a thing in software. If you converted that file to h.265/HEVC it should play without an issue.

1 Like

Correct. Resolution and frame rate are too high.

1 Like

Thank you both. I ´ll convert to HEVC and test. Thanks!

Thank you again for help. Everything works well and smooth after the conversion to HEVC and the folder mounted.

1 Like

Hello, just a question about how you use yours if you don’t mind?

Are you allowed to say what add on you use?