Play music on bluetooth speaker?

I am using a Raspberry Pi 3B+ running OSMC version 18.3 on my boat. I would like to output my music via bluetooth to my car radio (the USB output produces to much background noise).

When I try to pair it with the car radio, it says the connection failed. The radio shows in the list of paired devices with a red exclamation next to it.

I have tried to update everything both by GUI and by CLI, but it says there are no updates available.

I have tried to install a2dp-app-osmc but it says E: Unable to locate package a2dp-app-osmc,

when I run systemctl status bluealso it says unit bluealsa.service could not be found…

What do I need to do to get it to connect? If not on OSMC, would it work using plain Raspian running KODI? Or do I need to change to a different OS and setup completely (Jellyfin?) ?

I am not a whiz with linux so please detail any steps I need to take - I can follow recipes ok. I do also have a Samba NAS setup on this same RPI.



Newer versions of OSMC will handle this out of the box.

How do I get the newer versions? I tried doing the upgrades but nothing happened- didn’t even get to 18.7 never mind 19. It keeps telling me that no updates are available.

Or do I need to do a brand new clean installation?

It depends on how long you haven’t updated. Upload logs via MyOSMC - Log Uploader and share the URL so we can judge if you can upgrade or need a fresh install

Ok, I did a brand new install using the latest download. All went well except that I need to rotate the screen so I can read it (my projector is mounted upside down from the ceiling). Very hard working upside down!

I went to Pi Config and selected rotate 180 deg, but it does not work. Image is still upside down.

I also tried a brand new install using dietpi. On that, to get the screen to rotate, in config.txt I had to comment out dtoverlay=vc4-fkms-v3d But when I did that Kodi would not load and would exit with ‘unable to create desktop GUI. Exiting’.

If I put dtoverlay=vc4-fkms-v3d back in again, then Kodi loaded fine - but upside down. I am guessing it might be the same issue here?

So I still don’t have a usuable installation with either OSMC or DietPi. Any suggestions?

I’m guessing your projector doesn’t have an option to rotate the image or ?

Finally I gave up and used a fresh install of raspbian buster. I was eventually able to get the screen inverted by using the raspi-config menu and NOT selecting dt-overlay. Then followed the instructions on to get the speakers connect.

Glad to hear this now works for you.
I do note that you used Buster rather than Bullseye however – you may have some issues with the newer video infrastructure that Pi uses when you upgrade.