Play music, skin/vero hangs immediately, doesn’t react anymore, but music continues, only ssh reboot works

Hi, i had installed november-2 release.

Tonight I wanted to start some music, i played an album of alicia keys. After selecting the 1st song and pressed OK button to start, music starts to play, but a non circling circle came up, skin didn’t response at all, music continues. Ssh was possible and i had to reboot to get back into my vero 4k+.

I thought maybe this was fixed into the december release, but after installed that one, it stays the same result, music plays, screen hangs.


And it does it with each music file even of other artists.:thinking: OK or play gives the same result.

Even when using the kodi remote app, selecting a file the same skin frozen effect pops up.

The last time I listened to music was before the november-2 update.

2022-01-05 19:08:13.800 T:2909    DEBUG <general>: CFileCache::Process - <nfs:// Keys - ALICIA (Deluxe Edition) (2020)/Alicia Keys - ALICIA (Deluxe Edition) (2020)/06. 3 Hour Drive (feat. Sampha).mp3> source read hit eof

Looks like a network connectivity issue.
Have you tried playing the file from local media?



that for sure looks like such a problem, i’ll look into it.
All my movies comes from the same NFS NAS and they don’t show this.

I did copy a file from nas to local and then it played.
I selected a file from nas and it played🙃

I did notice that i had selected a direct nfs connection to my nas, while all the others went via the auto-fs connection. So i add music as well, cleaned the library and rebooted.

Selected the first file from nas and it hanged immediately.
Select file from vero and it hangs

I cleaned nas library for music
Selected the local file 01.mp3 from home/osmc/Music (which i gave library name of Muh)
It hangs while playing

Hope this helps

I don’t see the same error (EOF) in this log.

Nor do i, is there something i could start with ssh to find out why the entire screen is frozen?

For example i’m now playing a movie without any disturbances, so i agree it is weird……

If Kodi locks up on a file, it doesn’t always recover gracefully until the network comes back.

I do understand but now it’s playing an local file. Is there something then to exclude network issues? Now still playing a movie from the same Nas, without any interruptions or freezes.

If it only occurs on music, then it would be interesting to know…

It sure does, just watched a 2 hour movie without any interruptions.
Now play the same local mp3 and it immediately freezes, while music plays until the end of the song and nothing happens…

I didn’t had debug logging unfortunately

Probably caused by how Kodi buffers the files. Try a different mount.

I’ll setup another mount

/tmp is mounted

Plays as normal and screen does not freeze, this is odd

And then the other mount also plays fine.

I’m lost here.

And then after reboot tmo file was gone. So i decided to start playing from music, it froze again.

I was able from ssh to stop mediacenter.
I copied the same mp3 to /tmp as thats was empty. After copy played it again and it freezes immediately.

It seems to me something weird happens only with music playing.

I upgraded to devel, didn’t change it.

But after that i re-added home mount and then that same file played at once. Stopped it and selected a file from nas library and that played as well…. I can’t understand why it is not consistent in failing or playing….

After reboot playing the file from home mount, again freeze….

Did it again after debug logging enabled, same results

i did notice some others with freeze occurrences. Not sure if those commands can be used in my case of freezing while playing music (music keeps on playing, but skin frozen and only reboot via SSH can be performed.

So i took the actions from those posts

last one after reboot
osmc@osmc:~$ sudo journalctl -o short-full -b 0 --no-pager|paste-log

this is created before it happend
osmc@osmc:~$ sudo journalctl -o short-full -b -1 --no-pager|paste-log

this is the one created after all the commands
osmc@osmc:~$ sudo journalctl -o short-full -b -2 --no-pager|paste-log

hope it gives a clue

If you can login via SSH when Kodi freezes, this is good. It means you don’t have a hardware issue.

Kodi can freeze and lock hard when it can’t access a file and it can take a long time to recover.

When you say a freeze occurs, I suspect that sudo systemctl restart mediacenter will bring Kodi back fairly promptly.

The logs aren’t really useful – was hoping for full logs.



Hi Sam,

thanks for the reply.

i did test with stop and start which worked ok, didn’t test with restart, will try.

I was not sure if the journal logging also needed the extra logging, so i’ll add it and do the test again.


Here is the grab-logs -A output with all the logging enabled, after it occurred twice with restart mediacenter in between (which recovered skin). First played file from local (MUH), second played from NAS (different file) both froze skin.

list of journals created
0 after
-1 running music twice and restart mediacenter
-2 created log

-2 a15265dbf9c846a2b996076d8c0f2d85 Tue 2022-01-11 07:41:10 CET—Tue 2022-01-11 07:42:28 CET

-1 488b014eaddd458fb86cb6e796f9440f Tue 2022-01-11 07:42:38 CET—Tue 2022-01-11 07:47:40 CET

0 514b2f80249749ab8b2ea7bd6d99d171 Tue 2022-01-11 07:47:49 CET—Tue 2022-01-11 07:48:46 CET

osmc@osmc:~$ sudo journalctl -o short-full -b 0 --no-pager|paste-log

osmc@osmc:~$ sudo journalctl -o short-full -b -1 --no-pager|paste-log

osmc@osmc:~$ sudo journalctl -o short-full -b -2 --no-pager|paste-log

Hi @mtv,

So if I understand correctly, playback from a local source is OK, but playback over NFS is not.
I’ve seen issues playing some files over the network before when buffer sizes are small (particularly WMA files); but not MP3.

Does this only occur with the OSMC skin?

The scraping in the background causes a lot of log spam and it’s hard to follow the logs. It might also be the cause of the problem. Can you disable it temporarily?

Hi @sam_nazarko

I’m sorry, it’s a bit different. It plays from local only after the first creation, then even NFS will do :upside_down_face:. Then after reboot/restart they both won’t work anymore, until i recreate a new local source again…

I’m not using the OSCM skin right now, but the estuary skin.

I’ll search for the background scanning to disable it temporarily.


I disabled background scanning, didn’t made a difference (if you mean “disable update library on startup”)
I removed local source, and tried to play NFS file, direct hang.
I changed skin to OSMC and let it build up, as you triggered me here, trying to change skin if that would solve the issue.
I moved to Music (still the nfs source) and played same file, keeps on playing without freeze.
I rebooted vero
I moved to Music and played same file, keeps on playing without freeze.
I changed skin to estuary
I moved to Music and played same file, freeze direct.
I changed skin to OSMC
I moved to Music and played same file, keeps on playing without freeze from nfs.

I’m lost here.