Playback and Sound Quality Issues After June Update

I recently upgraded my OSMC from the December 2018 update to the June 2019 update. The update downloaded and installed without any issues, however I noticed 2 main issues after installation.

One of them is degraded sound quality on my Raspberry Pi 3 Model and the other is the inability to seek or skip on local video playback using my connected wireless mouse.

Before the update I could easily skip a video during playback now I can’t, clicking on that time bar does nothing but when playing audio files I can skip to wherever I want using my mouse, I just click on that bar and it goes there.

Here’s my log

ALSA …, so what is connected to the Pi instead of a pure HDMI cable to AVR/TV ?

In case there is no special sound card connected to the pi, this Wiki should help to check the basics.

Seems to be just the standard Pi sound device but accessed through ALSA.

m_displayName : Default (bcm2835 ALSA bcm2835 ALSA)

Isn’t that what Pis always report?

@object-Undefined what is the nature of the ‘sound quality’ issues?

Use PiSink if possible

It used to be like listening to true surround sound, but now the sound is just plain, I don’t know how to actually explain it.

Okay got it, anything on the video playback skip issues using a mouse. With the scrollwheel I can skip but using the mouse buttons to locate (click) the exact point I wanna go to it’s not working.

After checking that Wiki the sound quality is now decent.

Thanks :blush:.

1 Like

After a clean install of the June update, I’m still getting that issue whereby I’m not able to skip a video during playback to a certain point (time) by clicking on the time bar. I can use the scrollwheel without any issues to skip.

May you please look into this bug.

Does the issue persists even if using a different skin?

Just tried it with an Rii mini i8+ keyboard with a touch pad on that device. I can position the mouse cursor on the progress bar but there is no reaction on the left or right mouse buttons.
So, at least I can confirm and reproduce the current behaviour with OSMC skin.

No, there is no issues when using other skins.


Hopefully this skin issue is now addressed with the following commit: Fix mouse control of video OSD slider

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update (after the staging repository mirrors have synced in about an hour):

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Yes, can confirm that this is fixed with actual staging and the Rii mini i8+. :+1:

1 Like

Sorry for the late response, the update worked.

I had a “No such directory” error whilst trying to access that file so I edited this file instead /etc/apt/sources.list.d/sources.list.

Thanks for the swift response​:+1:t5::blush: