"Playback failed" error

Hi everyone,

I’ve added a share to my Vero 4K from my Synology NAS via fstab and the files (movies) show up fine in Kodi, but I can’t play back anything - al I get is the “Playback failed…” error.

I’ve tried both the SMB and NFS approach - no difference.

Any thoughts?




12:35:29.336 T:4077331024 ERROR: Error creating player for item /mnt/Film/Labyrinth (1986) (Atmos) HDR 4K.mkv (File doesn't exist?)

Kodi can’t seem to find the file, also you fstab entry doesn’t look correct to me: /mnt/Film        nfs     noauto,x-systemd.automount  0  0

Can you please provide the output of the following:

showmount -e

Thanks Tom.

Hi Tom,

this is what I get

Export list for

  • Erik


You need to update the fstab entry: /mnt/Film nfs noauto,x-systemd.automount 0 0

And reboot.

The other fstab entries for nfs are incorrect aswell, :/nfs needs replacing with :/volume1/relevant folder

so for example Musik: /mnt/Musik nfs noauto,x-systemd.automount 0 0

Thanks Tom.


I also notice you are only making the shares available to the vero4k (ip: which is fine if you don’t intend on having additional kodi boxes on the network, if you do wish to make these shares available to other boxes on the network; you can by changing to By going to NFS permissions on the share, edit the NFS Rule and update the Hostname or IP*

1 Like

Hi Tom,

now all I get is:

-bash: cd: /mnt/Film: Permission denied

Strangely, Kodi/OSMC doesn’t seem to update the shares either - I deleted everything but the “movies” share (and rebooted, of course) to make sure, but in the mnt folder, everything is still there but cannot be selected.

Is NFS on your NAS configured to be accessible without authentication?


This is do with permissions end on the nas. I’m assuming you trying to setup this share for play only, so read only permissions should be sufficient; please advise if this not the case?

On the synology under shared folders, select the movies shares and edit. On the permissions tap under guest tick read only. Under NFS permissions, edit the NFS Rules. Change Squash to Map root to guest.

Back on the vero4k, update the FSTAB entry: /mnt/Film nfs noauto,x-systemd.automount,ro 0 0

And reboot, should be good now.

Thanks Tom.

Still no luck.

  • Had forgotten to change the squash setting, so I changed that.
  • copy-pasted your FSTAb entry.

rebooted - no change. All the old FSTAB shares still show up in Kodi, probably meaning that my FSTAB changes haven’t been saved.

@Chillbo: How to do that?


Please provide the output of:

cat /etc/fstab

Thanks Tom.

#/dev/vero-nand/root / ext4 defaults,noatime 0 0 /mnt/Film nfs noauto,x-systemd.automount,ro 0 0

Do @Tom_Doyle’s hints help?


the NFS settings are set up correctly.

1 Like


Are you able to cd: /mnt/Film or do you still get the permissions error?

Also I think you need to remove the old sources from kodi, using the context menu:


Thanks Tom.

Still permission denied.

The old shares were already removed.

This can only be something about wrong permissions given to the NFS share on your Synology. The Vero 4k’s FSTAB line doesn’t have to do anything with the permissions on the shares’ side.

Are the shares configured to be accessible without any authentication (username+password) whatsoever?


What you got squash set to?

what are your settings on the permissions tab?

Any chance of a screenshot of the nfs rules pop up?

Thanks Tom.


I’m not entirely sure how to set that up. If I go under “user” → “guest” it looks like a username/password is automatically assigned to the guest account - any way to prevent this?


And the permissions tab between advanced & advanced permissions, there should be an admin and guest user.

Thanks Thanks Tom.