Playback freezes inconsistently over NFS

##Play freezes inconsistently over NFS

I have an NFS mount for my library and many times, when I’m playing my movies I get freezes which makes the viewing experience really annoying.
I’m able to distinguish two different, but consecutive kind of freezes. First I can see the buffering spin, once this gets filled, it may continue normally for
a few more minutes but then it freezes frames constantly, like every two to ten seconds. Some times if I stop the playback and resume, it continues fine for like 15 minutes
but eventually it starts freezing again.
So far it only happened with my 720p movies, I’ve seen SD tv-shows and those work fine.

All this happens in a freeshly installed Raspberry Pi 3 connected to my Router Netgear WNDR3400v3 (N protocol)

Any help will be much appreciated.

This is my configuration


<?xml version="1.0" encoding="UTF-8"?>

/etc/fstab: /mnt/NASDRIVE nfs noauto,x-systemd.automount,nolock,ro,soft 0 0

Do you have a cabled connection or are you using Wi-Fi! The Pi3 Wi-Fi is not that good so this might be the root issue, if you could temporarily connect us with a cable or use a different USB Wi-Fi adaptor it could help isolate the issue.

Two things might make a difference:

  1. Specify network cache settings in your advancedsettings.xml

  2. Specify NFS blocksize in /etc/fstab options, eg: /mnt/NASDRIVE nfs noauto,x-systemd.automount,nolock,ro,soft,rsize=32768,wsize=32768 0 0

I use a blocksize of 32768 but some people prefer 16384. It’s easy to experiment.

Hi dlopezleon,

I can recommended these video catching settings on kodi 17, with pi3:


Thanks Tom.

Hello ppl, thanks a lot for your replies.
I’ve tried everything u suggested and same result, eventually I get a freeze and never recovers until I stop or reboot, but eventually it’ll happen again.

@jb2cool, I’m on a wireless N network. It would be kind of difficult to get to the router by wire b/c it’s at 15ft of distance from the rPis.

I can give you more insight. Before trying my current rPi3, I had a rPi1 also with OSMC, with a Tp Link Tl-wn823n 300mbps and I was facing exact the same issue. I decided to upgrade before asking here just in case it was related to the Pi not being able to handle OSMC+NFS.

Is there some log about the playback I can check for finding a clue about these freezes?

edit: the NAS is just another rPi serving an NFS directory, may this be related to that? is there any way to diagnose this from the OSMC installation?


Can you please provide debug logs?

Thanks Tom.

Having the exact same issue and setup (only my wifi interface is external). Will try to provide logs.

We waited a year for the last guy’s logs, I guess it won’t hurt us to wait for yours…

I’ll get in up within a year :slight_smile:

Or, one could just make a post when they are prepared with logs and save us all the suspense and useless forum spam. Even more novel would be, instead of resurrecting a long dead and clearly abandoned thread with no clear cause or solution, create your own. As from a support perspective, we ultimately want to solve your problem without having to scrutinize what this long gone guy who opened this thread only halfway followed through with.

I’ve also just noted that we’ve been patiently waiting 10 months for your last promise to provide logs…


I’m sorry.

I’ve solved my issue simply by starting to use ethernet instead of wireless.

No worries, enjoy.

1 Like