Playback freezing / Kodi locking up


I bought a nice RPi3 recently and set it up now using OSMC. However, this particular problem also happened when I tried OpenELEC.

Whenever I stream a relatively big 1080p file with a ~10 Mbps bitrate, after a minute or two (sometimes less, sometimes more), the playback freezes, and Kodi becomes unresponsive for maybe a minute, before returning to the menu, with the playback stopped.

I am mostly trying with files streamed over 5 GHz wifi from my external hdd shared through SMB on my router, but it also happened with online videos. I am getting a reasonable 50 Mbps connection to the router, with only around 0,2 % packet drops.

I found out that I could solve it by changing cachemembuffersize in my advancedsettings to 0, thus caching on my SD card instead of the RAM. However, I’m not sure that’s such a good idea, as I heard that will pretty quickly wear down the SD card, with the constant writing to it. So, I’d much rather want to use my RAM for the caching… And as the RPi3 has 1 GB of RAM, that ought to be plenty, right?

Here’s my Kodi log:

My advancedsettings.xml looks like this:



I tried a lot of different combinations with cachemembuffersize and readbufferfactor, but only setting cachemembuffersize to 0 seems to resolve the issue. shows that I’m only using 30 % of my RAM when it happens, so it’s not because of a RAM meltdown.

My setup:

  • Raspberry Pi 3 (with Samsung Evo+ 32 GB)
  • OSMC June 2016 / OpenELEC 7.0 beta 3
  • Edimax EW-7811UTC wifi dongle
  • Archer C9 v2 router
  • External HDD shared through router

Thanks in advance!