Playback halted after one episode, after reboot always OK


I have a Vero 4K running Leia nightly versions. For the last couple of months (unfortunately I don’t know the exact version where I noticed a change) the first video file I play after a reboot works perfectly, however if I try to start a second one nothing happens. If I hit the back button all the way to home screen and then once more I can see a black screen with buffering (100%) but it will never complete.

After rebooting OSMC I can play any file I wish without problem, but the second video file stops in the same way.

I’m not too familiar with the logs or debugging but the one thing I keep seeing is CAEsinkalsa errors or amlvideocodec errors right around when the issues occur.

I uploaded a debug log to hastebin to help with troubleshooting. This is my first help request so let me know if you need further information.

In the debug log I played the first file at roughly 17:41 and tried the next which failed at 18:03.

This only happens to video files. Mostly I use local media files from my NAS, but I have also seen the problem from Netflix-media.

Do you have some tips for troubleshooting this?

Best regards, Andreas

Does this happen on v17.6?


Is 17.6 Kodi 17? If so, I have not tested the problem on anything other than Kodi 18 nightlies.

I used Kodi 18 nightlies for quite some time without issues and then I updated to a version which caused a reboot loop. Then I reinstalled from scratch to a newer nightly which did not cause reboot loop but this problem with only being able to play one video file occured some time after.


Does uninstalling the Spotify add-on resolve this for you?

I’ve tried disabling it, which did not help. I will try uninstalling and testing but since the problem takes some time to reproduce it might not be tonight.

It looks like Spotify was causing the issue, will update if issue is seen without Spotify installed.