Playback issue with specific HEVC 1080p video files

The issue I am having with OSMC is that no video is displayed when trying to play certain files that were encoded in a specific HEVC format at 1080p. This issue arrises when I play any file on the Vero4K+ with the same specific type of encoding.

I can reproduce this issue by simply playing a video file on Vero4K+ with this specific encoding such as this file (this is the specific file I refer to in this post).

At first I thought maybe the issue was related to the ASS subtitles that were in the original mkv file, so I striped those to test if that would fix the issue but it didn’t.
I’ve also tried playing around with some of the player settings one at a time, such as setting the ‘adjust display refresh rate’ to ‘always’, enabling ‘sync playback to display’, and setting the specific framerate of 1080p @ 23.37 fps in the whitelist of the system display settings. None of these worked to fix the issue.

One setting that did seem to make a small difference was disabling the ‘allow hardware acceleration with DRM PRIME’. When enabled (default) no video is displayed when playing the file (only a black screen is displayed). When this setting is disabled, video is displayed during playback but it is very slow and choppy and does stay in sync at all.

This is my first time coming across such an issue when playing any type of file on my Vero4K+, and that’s why I’m so surprised. I know this file and others with the same specific encoding are not corrupt because I can play them on other devices using VLC or even Kodi without any issues.

Here is the log file I created after trying to play the video:

Here is the mediainfo of the file I linked to above:

Difficult to say for sure without debug logs but I don’t think Vero supports 4:2:2 files of any resolution.

In detail: it can’t decode 4:2:2 in hardware and the CPU doesn’t have the power to decode in software using ffmpeg. I’ve got a 4k 4:2:2 clip which goes at about 1 frame per second with software but it looks like it can’t handle even 1080p video.

4:2:2 is unfortunately not supported

This is a studio format



1 Like