Playback issues 60fps


I’ve been running OSMC on my PI 2 for a while now and I love it, so far it’s been running every file I throw at it execpt for one mkv from my favorite FanSub supplier. (Big Anime Geek)

Seems they run parts of their show in 60fps, which was never a problem on my PC(Win7) and Kodi setup.

Sample file: SAMPLE

Any suggestions on how I can get this resolved? I’ve tried nothing and none of it worked! :wink:


Don’t know exactly what issues you are having with the file, but just downloaded, and it seems to play fine on my Rpi2.

Here is a paste from Media Info, and it is not 60fps, but 23.976 fps

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings, CABAC : Yes
Format settings, ReFrames : 6 frames
Duration : 23mn 40s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Title : h.264
Language : Japanese
Default : Yes
Forced : No
DURATION : 00:23:40.087000000
NUMBER_OF_BYTES : 312888620
_STATISTICS_WRITING_APP : mkvmerge v7.4.0 (‘Circles’) 64bit built on Dec 12 2014 12:19:56
_STATISTICS_WRITING_DATE_UTC : 2015-05-03 16:49:04

Would you mind trying this one? Sample2

In the first couple of seconds you should see a choppy pixelated images.

I’ll try to post a picture, if you want

The second one also play perfect.

This is what I see at the 0.44 seconds mark.

I see most of these at panning shots

Ahh, now I see it, when you said pixelated I was looking for something much worse than this :smile:
Yes I have the same problem here.

Great! well…not great… But at least I am not the only one.
So, now how do we solve this? :smile:

I really don’t know if it is a problem within OSMC or Kodi. Maybe somebody smarter that me can answer that.

Could you try this file and give me a read out, like you did with the other one?

Sample 3

I’d like to compare Sample 2 and Sample 3. :slight_smile:

Download does not work, its only a link to a png file.

Corrected that. :slight_smile:

From what could see, there is no problem with this file, the playback is fine and no pixelation in the colors

So it’s safe to say that it has to do with the way Yibis compiles their files, now all that is left is to figure out what it is and fix it. :slight_smile:

Use mediainfo:

Format profile : High 10@L4.0 

The files that play incorrectly use 10-bit H.264 (aka Hi10P). That is not supported by the Pi (or any hardware codec). You’ll need a decent specced PC to play these files with software decode.
Probably best to just avoid these encodings in the future.

Thanks for clarifying this. :smile:

Any idea if this will ever be supported or is it a limitation of the hardware?

It’s not supported by the hardware and decoding it by software is too much for the Pi to handle. So I would say never on this platform.