Playback issues in build 2021.08-1

I recently upgraded my OSMC hardware to a raspberry pi 3B (from a 1B) and when I was trying to set it up I discovered that videos encoded in H.265 1080p would not play at all (only sound and the blue player bar jittering) and videos encoded in H.264 would lag during high-bitrate scenes (camera sweeps, intense action) - in case of 1080p videos quite often and even sometimes in case of 720p videos.
I tried active cooling - no improvement. Increased GPU memory to 256MB - no improvement.
I run iperf3 tests to see if the connection was limiting me - stable around 90MB/s. Tried playback from USB disk - same as via CIFS (served by my NAS). I even tried to decrease my screen refresh rate to 30Hz, but it didn’t help either.
As a last resort I backed up all my settings and reverted to build 2020.11-1. And just with that, the lag on H.264 encoded videos disappeared. H.265 encoded videos still don’t play correctly (I read that it isn’t accelerated by the GPU on the pi 3B, is that right?) but at least I get some kind of video output, even if it is just still frames…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

HEVC isn’t accelerated anymore using QPUs on Pi 3 due to the new V4L2/GBM stack. So it will be software decoded, which won’t allow for playback of high bitrate material.

I read up on this, and this has to bee the problem. I’m not sure why Kodi decided to ship a new video decoding solution while the old one was working reasonably well, (and on the transition until it’s ready). Maybe there’s a good reason for this, but until it gets good I’ll revert to Leia.