Playback issues since last update

Hi, I got the OSMC update few days ago and now I can’t watch a movie without having the video slowed (the audio is fine) or for another movie the movie freezes for ~2 seconds every minute.
Well in fact, today the 1st movie which had the video slower than the audio is played fine… for some reasons…
But the second one still has those frozen images every minute (and the file is fine, I played it weeks ago without any problem)

Here is the log when I start playing the movie and it freezes right before stopping it:
Here is the NFO:

I didn’t log when playing the 1st movie since today it’s played fine. (at least the 10 first minutes)
I access those files on my NAS using ZeroConf

I deleted the temp files rm -r .kodi/temp/* but it didn’t fix it.

Should I rollback to the previous version? If yes, how?

It’s definitely unusable actually. I tried to watch some other movies (1080p, 2160p, x264, x265, …) and I experienced the same problem: the image freezes for 2 seconds like every 5 minutes.
(Or I got the video slowed for some reasons…)

Logs are very busy – lots of ffmpeg scraping in your debug log. It would be better to reboot twice to clear the log, and enable debug logging right before playback.

But you could also try the latest update as we’ve fixed a few bugs.

To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

I did everything you said and I guess it was updated but since the Vero 4K had to reboot, the update was stuck at 38% on Putty before loosing connection. But I guess it’s normal.

I still have the same issue btw :face_with_diagonal_mouth:
Here are the new logs without ffmpeg, audio, video, timing:
Here is a video “proof” just to show what I mean:
This one gets frozen for few seconds but yesterday I tried to watch another movie and it was fine until ~20 minutes when suddenly the video wasn’t synced anymore (I checked on my PC and file is fine)

What does it mean? :thinking:

I checked the logs now.
Reinstall OSMC as the system is tainted with 3rd party packages.

When we suggest an update that we push via our test repository, we do so in a way that ensures the user doesn’t stay on the test repository as they are unlikely to need constant access to such a repository. We don’t want them to experience experimental updates later down the road without reason.

So if you follow the instructions as advised above, a script will automatically delete the experimental update repository from your system after 14 days

I did:
Fresh install with last udpate: same issue
Update from your previous message:same issue
here are the logs:

The only difference is that I now have to redo all the library :skull:

So what file did you try and play? Was it Saw (1)?
There are numerous accesses to numerous files, with a number of errors:

024-05-25 06:18:24.710 T:3011    debug <general>: CFileCache::Process - <smb:// (2017).mkv> source read hit eof
2024-05-25 06:18:24.716 T:3011    debug <general>: CFileCache::Process - <smb:// (2017).mkv> cache completely reset for seek to position 4133436
2024-05-25 06:18:24.724 T:3011    debug <general>: CFileCache::Process - <smb:// (2017).mkv> cache completely reset for seek to position 4436179602

Usually indicative of connectivity problems

But you seem to be doing a library scan in the background or multiple thumbnail extractions which will be software decoded and tax the CPU.

Yes it was that one (Saw) that I tried to play, I also rechecked on PC (with VLC) and there is no freeze when played on PC.

I just have to scroll through the movies to find Saw so I guess you see all the image previews in the logs
I didn’t scrap the folder yet to not waste time. I simply added the source with ZeroConf.

I also checked Mary and the movie is fine on VLC, I spend lot of time muxing best sources and I check them before saving them on my NAS
But yeah, I have 1359 movies in that folder. I exported my Kodi Library and the xml file was 127mo and 2,8 millions lines

You have network connectivity errors in your log.

My guess would be that Kodi is trying to scrape too many files at once
If that’s the case it takes a while for scraping to complete and settle down

There are a few ways you could verify this – ex. put a file on local storage or external storage and try and play it.


Same issue. I removed my NAS folder in sources, reboot twice and played Saw from USB stick

I was 100% sure it wasn’t due to the network because I’m using RJ45 Cat 6, Saw is a 6300kbps movie and this issue is only from last update

Decoder opens fine.

Then we get these network requests

2024-05-25 07:17:04.581 T:2981    debug <general>: CurlFile::Open - <>
2024-05-25 07:17:04.582 T:2981    debug <general>: easy_acquire - Created session to
2024-05-25 07:17:04.586 T:2981    debug <general>: CurlFile::Open - <>
2024-05-25 07:17:04.586 T:2981    debug <general>: easy_acquire - Created session to

But once again I see a connection problem:

2024-05-25 07:17:02.948 T:3002    debug <general>: CFileCache::Seek - </media/9C72-D863/Saw (2004).mkv> waiting for position 4860999768
2024-05-25 07:17:03.003 T:3004    debug <general>: CFileCache::Process - </media/9C72-D863/Saw (2004).mkv> source read hit eof

If we hit EOF we have nothing to play.
If it’s a 6.3Mbps encode I am guessing it’s not too large. Can you play it off some attached storage or even the eMMC?

I’m pretty sure it’s because I hit “Stop” on the remote because the freeze just happened and I need to upload the log
This is my try with the file uploaded with Filezilla into the Vero4K itself:
I realized I had the NAS in another place so I also removed it there (I fucked up while adding the source for the NAS, I added it in File Manager instead at 1st and I forgot to remove it later but now it’s removed everywhere)

Same issue btw.

No sharing of feature films like this please. We aren’t a file-locker.
We will check the issue.


I downloaded your Saw 2004 file and played it on my 4K+. The video froze a few times momentarily and the audio also drops out as well. I played the file off a USB stick connected to the Vero. I run my 4K & 4K+ stock standard. I do not have any add-ons and only play movies/TV Series from external HDDs attached to powered hubs. I have a vast range of Movies/TV Series and they all play fine. I think there is something wrong with that video file of Saw 2004 you have. Hope this info helps.