Playback issues starting with OSMC

Greetings, all. I have be running OSMC on a RaspPi 2 for a little under two years now, and it has worked almost flawlessly in that time. With the most recent version update, including the updated UI and I believe Kodi Krypton, I have some mp4 files that now stutter on playback.

I have uploaded a Kodi logfile (link below) taken with two of the now-troublesome files and one larger, higher-bitrate file that plays perfectly. This is a hardwired RPi2 box (no wifi) and these two troublesome files play back normally on other clients, such as VLC from a wifi-based PC (no stuttering or frame drops). As is evident in the logs, the first two (BadExample1.mp4 and BadExample2.mp4) show consistent drops, while the higher-bitrate file (GoodExample1.mp4) render without difficulty.

I would appreciate any thoughts on why this might be happening; it surely seems as though this has some relationship to the most recent version update to OSMC. I am presently running OSMC March 2017 (2017.03-1).



  • I also have a Raspberry Pi 3 unit with OSMC (same version) that exhibits identical behavior on the same mp4 files.

  • I note that both of the “BadExample” files in the posted log are h264 files, while the other (non-stuttering) version is avc1; however, I sampled another h264 file on the box and it’s playback is perfect.


  • Further investigation shows that these problematic files exhibit the same stutter symptoms when played on a non-OSMC version of KODI Krypton on Android. In contrast, the “GoodExample” file shown here plays flawlessly on that same KODI install, which is connected via wi-fi. As a matter of verification of info I had posted previously, I again played these problematic files on VLC over a Windows 7 laptop connected via wi-fi, and they played perfectly.

EDIT 3 - Solution

Per my last reply below, enabling OMX Hardware Acceleration seems to have solved this issue.

Can you provide mediainfo output for the problematic files?

Will do asap.

Here are the mediainfo outputs for the two problematic files:

Bad Example1 mediainfo: BadExample1 - mediainfo -
Bad Example2 mediainfo: BadExample2 - mediainfo -

I believe I have solved this issue.

In researching generic KODI stutter issues, I discovered that sometimes toggling hardware acceleration can affect this behavior. When I went into system settings for video I found that OMX hardware acceleration was turned off on both OSMC boxes with this problem. I turned this setting on, restarted, and both files now play flawessly.

OMX is best avoided on Pi2/3, and shouldn’t be necessary

Video is still accelerated in hardware.

What would you suggest as an alternative solution, then? There is clearly a difference in the file rendering with omx enabled, so I’m not sure how I can avoid it. What’s the actual problem that makes it something to be avoided?