Playback jumps with a specific video

I have had no problems before using Vero 2 on Pi 2 connected to my NAS via ethernet, but playing this specific video has problems that look like frame drops or jumps. It plays back fine on my PC. Here’s the media info. Let me know if I should do a log too:
Complete name : \EXAMPLE\Multimedia$Video\Movies\Example\Example.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 699 MiB
Duration : 1h 46mn
Overall bit rate : 921 Kbps
Writing library : VirtualDub build 35491/release

ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : 2
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Muxing mode : Packed bitstream
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 1h 46mn
Bit rate : 799 Kbps
Width : 640 pixels
Height : 344 pixels
Display aspect ratio : 1.85:1
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.151
Stream size : 607 MiB (87%)
Writing library : XviD 65

ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Mode : Joint stereo
Codec ID : 55
Codec ID/Hint : MP3
Duration : 1h 46mn
Bit rate mode : Constant
Bit rate : 112 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 85.0 MiB (12%)
Alignment : Split accross interleaves
Interleave, duration : 42 ms (1.00 video frame)
Interleave, preload duration : 500 ms
Writing library : LAME3.99r
Encoding settings : -m j -V 4 -q 3 -lowpass 15.6 -b 112

A debug log would be helpful.


Here you go:

Thanks – log was helpful

Looks like PTS is dodgy in the video. I have done some work on improving playback when this is the case. It will make next month’s update, but I’ll let you know when something is ready for immediate testing and would very much appreciate your feedback to see if things have improved.



Sorry, but what is PTS?

Presentation Timestamp. It’s a way to keep Audio, Video and Subs synced. Unfortunately, with scene releases, and old containers like AVI, they’re not always existent, or necessarily valid.

Learn more here: ffmpeg tutorial.


Then you night also like to know that the subs were way out of sync. (They were english so I didn’t need them.)

Without the file itself, I can only guess what the issue for this specific file may be, but I have a fair idea.

I’ll let you know when there’s a test build.


Let me know when and I’ll give it a go.

A test build is now ready:

wget -O mediacenter.deb
sudo dpkg -i mediacenter.deb
rm mediacenter.deb
sudo reboot

Didn’t fix it sorry. Here’s the log:

Hi Sam
I’m pretty sure my problem is the same as this thread:

It is also affecting videos that previously played back OK.

Try an update via my OSMC. We have had some positive reports tonight

1 Like

This hasn’t fixed it for me, but I see there is a new version for testing 1 hour ago on the other thread. I haven’t tested that yet, so I will jump on that thread to try and keep it all in one spot.

I had 2 skipped frames every 10 seconds with xvid (with dc:ff-mpeg4).
I had poor performance, with 10 drops per minute with dc:am-h264.

With the vero2-mediacenter-osmc_16.1.0-8 I’ve seen no skips and no drops.

But now, Big Buck Bunny full HD skips.

I’m joking :relaxed:

So – just to clarify, all is well?