Video playback issue since last may update

Hi there,

today I figured out that MPEG4 videos are stuttering in an interval like 10 seconds since the last may update. During the video lag the audio is still fine. When I watch HD videos this issue does not happen. I also checked an old video which I had seen before the may update. Now it’s also stuttering. Before the may update everything was fine.

I found this topic with a similar problem:

After installing the test build the issue does still exists. Is there any explanation for this issue? If you need some logs please let me know.


Yes, some logs would be useful

It would also be good to know the last update it worked well on


Hi Sam,

i attached the kodi.log and also an output of the mediainfo.

The last update runs very fine on my Vero2 except having the sad smiley (with an automatically restart of kodi) one time after I used the youtube plugin. For me it feels very stable.

If you need further information, other logs or anything else let me know.


Same thing happens to me.

With the may update, I have either video freezes on every 10 seconds, or one 5sec long video freeze per movie.

Neither vero2-mediacenter-osmc_16.1.0-5, nor playing from flash helped. Playing from flash made the 10s interval freezes worst.

The 5s video freeze could be network related, because I cannot reproduce it.

trolling: I wish we had more distros with rollback support (Nix or git based)


If this is a regression, then I believe I’ve identified the problem and will have a fix for it shortly.

I have looked at ‘rollback’ support for the future. Git as a filesystem is nice, but severely limits the ability to expand the system.


1 Like

I also experience small stutters in HD videoes, every 10-15 sec.

But sounds nice, if a fix is on the way :slight_smile:

Please try the latest update. You can update via My OSMC -> Updater -> Manual Controls -> Scan for updates.

I tried, but I got the message that there are no updates availlable :frowning:

Are you behind a proxy?

Try again shortly – it’s possible your ISP is caching our update server.

No I am not behind a proxy but after rebooting the system the update dialog was shown correctly.
So … after updating I tried to watch the video files which had this stuttering but sadly the issue is still there.


We have reverted the only change to Video Playback that was made in the May update for Vero 2.

Are you definitely sure this file played ok in the April update, can you reinstall the April version and double check?


@noXtreme just to clarify, you tried playing /Volumes/Media/Series/Gossip Girl/Season 1/isd-gossipdxvid-s01e01.avi as reported in your earlier post, and this was the file that still exhibited problems with today’s update?


I tried a few more files which I had seen before the may update and which worked definitely well. I also double checked the lastPlayed date of the movies in the database and I definitely watch them in the middle of April.

Yes all files (except HD videos) which worked well last month are still affected with the stuttering effect.

Is there any way to try a fresh install on the SD card and boot from it without touching the current system which is on the internal storage? Otherwise I have to reconfigure my whole system configuration which takes a bit more time.

Not at this time – as there hasn’t been much demand for this feature, but in the interim we will keep working on this problem

Okay, so I will try a clean install with the april-version on my current system and let you know when I am done.

1 Like

The affected video files which I watched in the middle of April are fine with the April update but are stuttering in the May update. But the strange thing is I also found video files which also stuttered in the April version too.

So, April version is a bit better but also have this issue on other (older) files. Do you need more log files? Should I also try the February Update?

Ideally I want to focus on fixing what worked before and now doesn’t before looking at other clips as well.

I am building a new version of Kodi and you will receive an update notification when it’s ready for testing (a couple of hours).


FYI, I also re-installed the April Vero2 img, and all problematic files (older xvids/game of throne etc…) are now fine.

The version from yesterday (as well as 1st May) is problematic.

@sam_nazarko Could it be that this issue depends on the divx codec? I mean every file on my system which occurs this problem has the divx/xvid codec.

Possibly. I would be surprised if yesterday’s update still doesn’t yield improvement for you