Playback keeps stopping and returning to menu or jumping ahead

Hi All,

I’ve been having this issue for a while and getting no further to solving it, hoping you guys can assist :slight_smile:

I have a Raspberry PI connected through a set of powerline adapters and a netgear router to a Lubuntu machine which stores my TV shows.

I have reset my routers, rebuilt the Lubuntu machine and the raspberry PI to ensure all equipment is using default settings, but still no joy.

The issue is that when watching a TV show, playback will either jump ahead a few seconds and continue as normal and/or playback will stop and return me to my list of TV shows.

I’m unable to try a wired connection to rule out wireless and have also tried editing the advancedsettings.xml file to try various things.

Try playback from a local storage first?

Sam

Thanks Sam,

I will copy the last TV show that kept playing up and play it from a USB stick connected to the pi.

Update: I have successfully watched two TV shows via a memory stick connected to the pi.

Guess this will relate to a source computer/powerline network issue.

Are there any logs I can look at when it next freezes?

Hi,

Logs are located /home/osmc/.kodi/temp/kodi.log.

I’m accessing my shares via powerline, with no issues. What are the shares samba of nfs?

What changes did you make to advancesettings.xml?

Thanks Tom.

Hi Tom,

I believe it’s samba as its connects via smb using a username and password.

I tried numerous changes to the advancedsettings.xml over the last couple of weeks but have since reverted back to default.

Hi,

Being as your using Lubuntu, you should consider using nfs; I’ve found it has better throughput than samba and you may find it more stable than your current setup. Details can be found here:

Thanks Tom.

Thanks Tom, will take a look at that article. Will i need to complete all 9 steps on my Lubuntu system?

Steps 1 to 4, for lubuntu. Remaing steps to be carried out on the pi.

Thanks Tom,

Sorry for all the questions, but after the Lbunutu part is complete, can’t you just browse to the nfs share using file manager on the PI?

Hi,

Yes.

Thanks Tom.

Thanks,

Have just switched to nfs, will see how the next few days go when watching tv shows. Hopefully this long outstanding issue will now be solved.

I hope so

Unfortunately it froze again twice during a 40 minute TV show? :frowning:

Hi,

how did you mount the nfs shares in the end? If you went via browsing nfs via kodi, you could try kernel mounted (fstab)

But before you try that I would recommend adding a video caching to advancedsettings.xml.

Which pi are you using, if its a a pi3 I recommend these:

<advancedsettings>
	<cache>
		<memorysize>157286400</memorysize>
		<buffermode>1</buffermode>
		<readfactor>4.0</readfactor>
	</cache>
</advancedsettings> 

Thanks Tom.

Hi Tom,

I believe i have the Model B 512MB Raspberry Pi

Hi,

You could try:

<advancedsettings>
  <cache>
    <buffermode>1</buffermode>
    <memorysize>52428800</memorysize>
    <readfactor>4.0</readfactor>
  </cache>
</advancedsettings>

This will use 50 mb of ram for the buffer. You can play with memorysize, but I wouldn’t go any higher than 75 MB.

This site: http://unitconverter.io/megabytes/bytes/75 has a good megabytes to bytes converter.

Thanks Tom.

1 Like

Thanks Tom,

I have just applied the settings now and will report back. :slight_smile:

Thanks