Playback problems with 4k content


I have issues that I think started with the last update.

All my 4k and/or content is just refusing to play.

I have the vero 4k+ plugged into a marantz 6012 AVR and the amp connected to a Optoma UHD65 Projector. All worked fine with the same content for months with no issues.

If the resolution for the ui is set above 1080p then the avr and projector does not reliably sync.

Playing any content avove 1080p fails, with occasional chirps of audio and a black screen.

I applied Oct update manually from command line (apt-get update;apt-get dist-upgrade)

Any ideas?



I can get my display back if I DISABLE The ENHANCED 4K SIGNAL FORMAT IN MY AMP. Enhanced has never been switched off before.

Were there any 4:4:4 / 10bit chnages in the Oct update?

(Enhanced supports 4k 60p 4:4:4, 4:2:2 or 4K 60p 4:2:0 10bit.)



As you seem to know how to use the command line, please try this:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi Sam,

Thanks for the fix.

Sad to report that this did not work for me.

Symptoms remain exactly the same.


Can you post fresh logs after applying this update so we can check things have updated correctly?


New Logs:

Nov 28 22:36:29 livingroom mediacenter[732]: --> 32768 Nov 28 22:36:29 livingroom mediacenter[732]: smbc_read(0xd70499c8, 32768)

You have a lot of log spam from SMB logging.
If you have component based logging enabled, please disable it.

Do you have attr set in rc.local? If so, remove it.

There is also something funny with that log - the Kodi.log is less than a second long. Please set ENHANCED on your amp, set debug logging on, reboot with the GUI in 1080p then try playing a 4k24Hz video and grab the logs.

rc.local just contains this

iw reg set GB

I have no option for debug logging in Settings->System->Logging
(am in expert mode )

i removed guisettings.xml to allow it to be recreated, but this didn’t get me the option back.

Very strange.

Any ideas?

You have this in advanced settings:

<loglevel hide=“true”>-1</loglevel>

I don’t actually know what that means without looking it up but suspect it’s relevant.

You are correct.

No idea why that was in there.

New logs are here.

Thanks for your patience.

During that time, were you using the HDR auto switch and/or setting 10 bits in rc.local?

Could you try echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr.

I think i was using the hdr auto switch.

I never had anything in rc.local

After running echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr the video plays.

On reboot i am back to having the problem as you would expect.

If i play the content its stutters and the projector does not sync, If i issue the command, while the vid is running it syncs and the content starts to play. (albeit a bit garbled) A stop and start then gets it back working.


It looks like you would benefit from our up-coming ‘force 422’ switch. If you echo 422now while the GUI is showing I hope you will be able to play all content. If that works, put echo 422 > /sys/class/amhdmitx/amhdmitx0/attr in rc.local.