Playback Video - sound stuttering after March 5th Update


#35

Thank you! This fixed the issue.


#36

Downgrading the kernel works for me. So is the solution really to not upgrade the kernel if using a RPi? Or is there something that can be done on OSMC side?


#37

Try the new kernel

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


#38

Hi Sam,
Sorry, but the issue is still there, at least for me. It feels like the dropouts are somewhat fewer, but they are still there. Would be good if someone else could confirm this as well.


#39

The issue is still there for me too after March update, on RPi2. The video files are on some NFS share (fstab).


#40

Even after downgrading manually the kernel?


#41

Sam posted update instructions for an even newer kernel yesterday. The instructions are the same as previously, but the kernel in the repository had been updated. The new kernel, as of Sam’s post yesterday, does not work for me. Please try it yourself, and confirm my findings. Like I said, it seems a bit better, but it is still not as good as the old one (Linux osmc 4.9.29-10-osmc).


#42

Yes, I’ve got micro cuts back with the newer kernel. You’re right Buckley.

Back to January update kernel for me, otherwise kids cannot watch cartoons anymore and my wife will have my skin. :slight_smile:


#43

Did you try enabling OMX player?


#44

I watched an mkv movie after the update and haven’t noticed any stutters. Watched for about half an hour. Had the issue previously and downgraded the kernel as per Sam’s instructions and was fine then as well. Will have to do more tests but I seem to be ok with the newest update and it’s newer kernel with MMAL enabled. Pi3 is my hardware.


#45

I have similar problems after the March 2018 update. Raspberry Pi 2 B rev 1.1.

I’ve downgraded the kernel from 4.14.26-1-osmc to 4.9.29-10-osmc, but that did not help.

I tried enabling the OMXPlayer, but that was just worse – black screen and no audio when playing back video files, so turned off again.

Trying to playback a recorded football match, I get the following messages in the log file:

19:55:50.180 T:1925810688  NOTICE: VideoPlayer: Opening: nfs://192.168.1.11/videos/TV/20180313 2030 - Viasport 1 - Fotball_ Roma - Shakhtar Donetsk.ts
19:55:50.180 T:1925810688 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
19:55:50.181 T:1182790400  NOTICE: Creating InputStream
19:55:50.613 T:1182790400  NOTICE: Creating Demuxer
19:55:50.927 T:1182790400  NOTICE: Opening stream: 1 source: 256
19:55:50.928 T:1182790400  NOTICE: Creating video codec with codec id: 28
19:55:50.928 T:1182790400  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
19:55:50.932 T:1182790400  NOTICE: Creating video thread
19:55:50.933 T:1082127104  NOTICE: running thread: video_thread
19:55:50.933 T:1182790400  NOTICE: Opening stream: 0 source: 256
19:55:50.934 T:1182790400  NOTICE: Finding audio codec for: 86019
19:55:50.936 T:1182790400  NOTICE: Creating audio thread
19:55:50.938 T:1073738496  NOTICE: running thread: CVideoPlayerAudio::Process()
19:55:51.292 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:51.292 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:51.666 T:1203761920  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
19:55:52.121 T:1182790400  NOTICE: Opening stream: 1 source: 256
19:55:52.122 T:1182790400  NOTICE: Creating video codec with codec id: 28
19:55:52.138 T:1182790400  NOTICE: Opening stream: 0 source: 256
19:55:52.173 T:1073738496  NOTICE: Creating audio stream (codec id: 86019, channels: 2, sample rate: 48000, no pass-through)
19:55:52.318 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:52.319 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:52.448 T:1925810688  NOTICE: Display resolution ADJUST : 1920x1080 (1920x1080) @ 50.00 - Full Screen (16) (weight: 0.000)
19:55:52.934 T:1082127104 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
19:55:53.352 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:53.352 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:53.385 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:54.176 T:1895908096   ERROR: ActiveAE::FlushEngine - failed to flush
19:55:54.378 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:54.379 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:54.594 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:55.405 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:55.407 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:55.432 T:1886384896   ERROR: CActiveAESink::OutputSamples - failed
19:55:55.446 T:1895908096 WARNING: CActiveAE::StateMachine - signal: 10 from port: OutputControlPort not handled for state: 1
19:55:55.446 T:1895908096 WARNING: CActiveAE::StateMachine - signal: 11 from port: OutputControlPort not handled for state: 1
19:55:55.802 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:56.496 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:56.497 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:57.010 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:57.523 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:57.524 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:58.219 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:58.551 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:58.554 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:55:59.427 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:55:59.580 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:55:59.580 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:56:00.606 T:1886384896   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
19:56:00.606 T:1886384896   ERROR: CAESinkPi::AddPackets timeout
19:56:00.632 T:1886384896   ERROR: CActiveAESink::OutputSamples - failed
19:56:00.635 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:56:08.775 T:1925810688   ERROR: Previous line repeats 6 times.
19:56:08.775 T:1925810688  NOTICE: CVideoPlayer::CloseFile()
19:56:08.775 T:1925810688  NOTICE: VideoPlayer: waiting for threads to exit
19:56:08.776 T:1182790400  NOTICE: CVideoPlayer::OnExit()
19:56:08.776 T:1182790400  NOTICE: Closing stream player 1
19:56:08.777 T:1182790400  NOTICE: Waiting for audio thread to exit
19:56:09.087 T:1073738496   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
19:56:09.088 T:1073738496  NOTICE: thread end: CVideoPlayerAudio::OnExit()
19:56:09.089 T:1182790400  NOTICE: Closing audio device
19:56:09.092 T:1182790400  NOTICE: Deleting audio codec
19:56:09.093 T:1182790400  NOTICE: Closing stream player 2
19:56:09.093 T:1182790400  NOTICE: waiting for video thread to exit
19:56:09.094 T:1082127104   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
19:56:09.095 T:1082127104  NOTICE: thread end: video_thread
19:56:09.098 T:1182790400  NOTICE: deleting video codec
19:56:09.111 T:1925810688  NOTICE: VideoPlayer: finished waiting

Any further help appreciated!


#46

Just tried the 2018.03-2 update, and initially, that worked fine playing back the same video. After a couple of minutes, the sound started crackling, then the video and audio started stuttering. The log started showing the same messages again. When I stopped the video playback, the GUI sounds in Kodi were no longer working.


#47

Which video player do you have activated?


#48

Default settings, hardware acceleration is disabled for OMXPlayer, enabled for MMAL.


#49

I’m having the same issues.

I have made some observations.

On files with DTS audio I dont get the dropouts. Perfect playback of both audio and video.

On Dolby Digital, or any other kind of audio encode (MP3 / AAC / other) I get intermittent audio drop outs.

I must add, that hey never occur in the same places. If I rewind back past the dropout, or restart the file, the dropouts occur at new places.

When playing, if I keep an eye on my Audio Receiver, it never shows that it looses audio sync. It displays e.g. Dolby Digital, even when the audio drops out.
I notice a pattern of getting a dropout, then the audio is shortly out of sync, then a dropout, and the audio is back in sync.

I have reverted to the previous kernel provided by Sam earlier in this thread, and the problem has dissapeared.

Please fix this :slight_smile:

I suspect it could take some time, if the problem is in the kernel, but I’ll keep my system downgraded until a fix is found.

My player is a Pi3.


#50

The video file breaking my OSMC/Kodi is a TV recording:

  • TS container
  • video: H264 MPEG-4 AVC 1920x1080i, 25 Hz
  • audio 1: A52 / AC3 audio
  • audio 2: MPEG audio layer 1/2 48kHz stereo

Audio output is 2 ch analogue, video output is HDMI 1920x1080@50Hz.

I’ve also tried playing back other formats, no problem:

  • AVI container
  • video: MPEG-4 (DivX) 640x352i, 25Hz
  • audio: MPEG audio layer 3, 48 kHz stereo

and

  • M4V container
  • video: H264 MPEG-4 AVC 720x576i 25Hz
  • audio: MPEG AAC, 48 kHz stereo

For information, I’ve played the problematic video file on the original recorder (DreamBox), VLC and Kodi 17.6 in Fedora 27/x86-64; none of them have the playback problem seen in OSMC on my Pi2.


#51

i had frequent audio dropouts (waf<0;-) using the latest kernel (4.14.26-2) reverting to 4.9.29-10 cured it.

btw, i am running s/d’s hdhr_record very successfully on the rpi2, altho the kodi plugin reliably crashes when rewinding live tv


#52

Yup, still have this issue with 4.14.26-4 kernel. Seems to only affect DD and DD+ soundtracks that I’ve noticed. Less frequently than the current stable kernel but still present. 4.9.29-10 works perfectly as was posted above.


#53

I’m also experiencing audio stutter since march update.

I have my music library on a usb drive and in my dmesg I found flood of lines like this:

[ 2029.885987] WARN::dwc_otg_handle_mode_mismatch_intr:68: Mode Mismatch Interrupt: currently in Host mode
[ 2081.598981] WARN::dwc_otg_handle_mode_mismatch_intr:68: Mode Mismatch Interrupt: currently in Host mode
[ 2099.705987] WARN::dwc_otg_handle_mode_mismatch_intr:68: Mode Mismatch Interrupt: currently in Host mode
[ 2141.075999] WARN::dwc_otg_handle_mode_mismatch_intr:68: Mode Mismatch Interrupt: currently in Host mode

Perhaps this is another problem…

Marco


#54

@sam_nazarko

I have to ask:

Are you and the team working on solving this problem?

There have been no replies here since the last kernel that was supposed to fix the problem was released.
And some people (myself included) are still experiencing problems, and have to downgrade to the 4.9.29-10 kernel, where the problem is not present.