Playing 4k movies with 4K60 EDID

I run all of my devices inside a closet connected to an 8x8 Matrix HDMI Switcher KD8x8CSK (http://keydigital.com/product.aspx?ItemCode=kd8x8CSK). There are 4 TVs in the house that have long HDMI cables running to the closet and plug into the switcher. Three of the tvs are 4K, a Sony, a Toshiba, and a TCL.

I do not know if this problem started recently with the last one or two updates or if it has been there a while since my kids have been using it more then I have lately. But when I try to play a 4K movie with the EDID set to 4K @60 and 2 Ch audio by the switcher the format that is sent is not playable on the TV.

Logs are here: https://paste.osmc.tv/ogilejanaf

The file I was trying to play with the above log is here:

If I set the EDID to 4K @ 30, the video will play but will becomes slowly unstable and eventually freezes - I am able to still hit stop to exit the movie. If I start a movie with chapters that is 4K that show the same problem but hit Next right away before it freezes it will usually show the sad face and reboot.

I have tried different playback settings. Turning sync on and off. Adjust display refresh (usually leave it on start/stop). Nothing seems to make a difference. Normally, I have the GUI set to 1080p. If I set it to 1080i, it seems that it forces all moves to play in 1080i so they are actually watchable that way.

Let me know if you want more logs in other configurations.

The EDID being received by Vero is garbled. Let me have a look at your switcher manual and figure what’s going on. It may be a while, (later today) unless someone else can chime in.

Update: The EDID is inconsistent: a mixture of 4k2k60Hz and 4k2k30Hz and does not indicate support for YCC (YUV) which is essential for 4k UHD. Weird. I suggest you use the EDID copy function to clone the EDID from one of your 4k TVs to the input you are using the vero on. If that doesn’t work, post logs again.

@grahamh Ok, thanks for looking at it. Ya, that is weird. I also have an Nvidia Shield with Kodi installed and with the same edid it seems to work just fine. I will try as you suggest and copy an edid from a TV.

Just so I dont have to keep uploading logs constantly, can you tell me where exactly you see the lack of UCC support is? Is it something here?:

YCC support 0x00, VIC (native 255):
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1
353 16 31 4 19 5 20 32 33 34 93 94 95 352 101 102 98 99 100 7 22 3 18 95 94 93 98 609 608 357 358

What if I change one of the color overrides in the Playback or System-Video settings? (under Expert view)

YCC support would typically be 0x03, meaning supports YCC444 and YCC422. Probably the Shield just ignores that, always expecting to be talking to a TV, not a PC monitor.

Vero will be sending RGB which just doesn’t work for 4k60Hz UHD. Nothing to be done in settings, I’m afraid.

The EDID presented by the matrix switch does have a Y420VDB with support for 4K 50/60. I copied the EDID to a HDFury Vertex and tried it on my LG OLED. With a 4K 60fps clip, Vero 4K switched to 4K 60Hz YCbCr 4:2:0 and it displayed on my TV. On nVIDIA Shield, you get RGB modes in addition to YCbCr 4:2:0 for 4K 50/60. It didn’t present YCbCr 4:2:2 options.

Can’t really say why OP’s TV doesn’t display the 4K 60Hz signal. Something in the chain that’s not HDMI 2.0?

1 Like

That’s odd. Are you sure you pressed ‘Upload EDID’ :wink: As I said, there’s no YCC support advertised and the max tmds clock is only 300MHz. We default to 10 bits now and you can’t send 4k60Hz RGB at 10-bits on HDMI2.0. I’ll check if we have a fallback for that, but if we don’t it’s not surprising the OP is not getting a picture.

Yes, I’m sure! It outputs 4K 60Hz 4:2:0 8-bit BT.709.
Y420VDB is not dependent on YCbCr 444/422 support in the main VDB. At least this is how CTA 861 should be interpreted.

Well, from my end, it seems the advice to use an EDID from one of the TVs did the trick. I actually copied it to ALL 4K input sources (the Shield as well as a Roku Ultra) and they are all working as expected. Seems that HDR was not being allow in any of the devices because of the built in EDIDs which I never realized until I started seeing the TV indicate “HDR” when showing current video format.

I am guessing that the build in EDIDs are just plain old. Short of a firmware update from Key Digital, I will avoid using them for the future.

Thanks for all of the help guys. It is much appreciated. I really like the device and glad we could make it all work.

2 Likes