Playing a bluray folder

I got a bluray disc that simply had its folder structure (+ files) ripped. I would like to play this from the main folder, just like playing from a bluray drive.

This worked with Kodi on a (linux) PC. But not on the Vero 4K. Looking at the log, I get the error:

DEBUG: CDVDInputStreamBluray::Logger - index_parse.c:184: index.bdmv failed signature match: expected INDX0100 got INDX0300

The kodi version on my PC is 17.6, built Nov 18,2017 (for linux x86_64). I just updated the Vero 4K, and also installed libbluray1. The kodi version (on the Vero4K) is the same: 17.6, compiled on Mar 12,2018.

Will this just not play on the Vero 4K (at this moment)?



I can upload the full log, if needed. But, IMHO, the above message makes clear what the error is.

UHD disc? Newer libbluray is needed, rudimentary UHD support (without BD-J support) was added with version 1.0.2. OSMC comes with an older version right now… Don’t know if you just can upgrade the lib or if a Kodi recompile is needed / works. Sam?

I remember seeing such a message some time ago. I wasn’t able to test if a new version would be beneficial and IIRC the Nevcairie patch series wouldn’t apply.

I’ve built libbluray 1.0.1 now and you can try this. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Did that. Same error still there. I did notice that libbluray did get upgraded.

I have uploaded logs to:

Let me know what else you might need.



I think support is not there yet for this type of disc.

I will only point out that - as I said initially - the linux PC version of Kodi did handle this. It’s not a big deal for me, since I only have one bluray video folder. Everything else has been ripped to mkv.


I’ll look in to this further, but can’t give a firm ETA at this point


I’ve got this same error:

DEBUG: CDVDInputStreamBluray::Logger - bluray.c:1384: libbluray version 1.0.1
DEBUG: CDVDInputStreamBluray::Logger - bluray.c:1409: BLURAY initialized!
DEBUG: CDVDInputStreamBluray::Logger - index_parse.c:187: index.bdmv failed signature match: expected INDX0100 got INDX0300

Now apparently this should be fixed in the new libbluray version 1.0.2. Is there anyway to test this? I have a Vero 4K.

See the changelog and search for “index”:;a=log;h=refs/tags/1.0.2


I work around would be to mux to main m2ts track to mkv using something like or make mkv

We will update libbluray for Leia


Now that v18 is out, can full bluray support be expected? Tried some, but issues seem to be present. Should Java or something else be installed / enabled somehow?

Only thing remaining for the device to be perfect. REMUX is not ok for concert blurays…


Maybe you should follow this thread?

thanks. missed this. anyway, seems too complex for me at this time. let’s see if it becomes an easier solution in the future.

1 Like