Playing Dolby Atmos Blu-ray audio

Hello
I have The beatles the abby road with bluray audio in atmos , when I chose atmos mode ( as its available in stereo , DTS and atmos ,
When I chose atmos mode the sound is interrupting while in other modes no problem !
Its the first media file i get problem with
Im using Samsung Q90r soundbar , the file extension is mts2 extracted from original bluray ,
So whats the solution?

Log is here https://paste.osmc.tv/awoxetivel

Thanks

Does this happen on other Atmos tracks?

No its the first time happens

I mean only on this audio

Just for info , i tried using vlc player on my xbox one s , it worked on atmos

So can we add vlc on osmc?

Unfortunately you won’t be able to run VLC on OSMC with hardware acceleration.
Can you produce a sample of the clip so we can test it locally?

Sam

Its a large file i will try if I can

This is the same problem others have had with Atmos and movies. Kodi devs are working on it.

But if you could upload a short sample which shows the problem we can have a look at it.

Good spot.

I wondered if it was MAT frame related, but as it wasn’t Disney wanted to get a sample.

Also I don’t think CDVDAudioCodecPassthrough is where kodi devs are looking atm. First sighting of this on an ‘audio’ file.

1 Like

Its difficult for me to cut the file to get a sample

Can use ffmpeg to just cut a 1 minute piece

You can also use mkvtoolnix To make a sample if you prefer something with a GUI

Thanks i will try

Hi,

I have the same issue with the same soundbar.
MKV’s with atmos are working well.

I’ve also got the Abby-Road BR, and can confirm the kodi issue with the Atmos track on it. In my case I went to the extent of ripping just the audio track to mka files (and mkv) to isolate just the atmos track.

It sounds like a clipping issue, as its the loud parts where it cuts out. Quieter parts seem to be ok, but when you get a heavy base-line, it drops. “Come Together” is a great example. The opening bit with the heavy base-line drops a lot, then the quieter verse is fine, then it drops again when the base-line kicks in again.

I’ve got another (non OSMC) device which has the same issue, so its not an OSMC thing.

I don’t think anything can be done about it until the core Kodi audio libraries are fixed. (related to ffmpeg from what I’ve been able to understand of the discussions)

You’re correct. It’s not unique to OSMC.

It is being worked on upstream and we are working with Kodi to expedite the process.

Cheers

Sam

Thanks for everybody so waiting for fixation

It seems that m2ts files are not well supported as mkv files ,
Now I have another m2ts music video file with dolby atmos have the same problem
And another one playing like fast forward mode and sound disruption

The issue is independent of container