Playing Hi-res audio files

I’m having problems with Hi-res audio files in my Vero 4K OSMC.
I can play mp3 without any problem.
I can play flac files in CD quality without any problem (16 bit).
But i cannot play flac files in hi-res quality (24 bit). It seems to play in the player, but no sound at all.
Any idea what could be wrong ?
Thanks in advance for your help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks.

In the logs i can indeed find:
WARNING: CreateLoader - unsupported protocol(music@smb)

Please find the complete logs in https://paste.osmc.tv/cosukucude

Any idea what could be wrong ?

The problem is not the file, it’s the path to the file:

 music@smb://plitvice/music/HIRES/Michael-Jackson/Bad-Remastered/1_1_Michael-Jackson_Bad_7.flac

I don’t see for sure how the music@ is being prepended to the path, but that’s what seems to be causing the error.

That’s strange because that’s exactly the same path to mp3 or flac 16 bit.
Moreover the metadata of the files are correctly displayed and it seems to play, it’s just that no sound is produced for hi-res flac 24 bit.

Please enable debug logging and upload logs again.

And are you able to play these files from a local drive?

Please find latest logs here: https://paste.osmc.tv/duxomabore

I’ve tried to play two different flac files:
1.
2020-01-22 18:20:53.686 T:3824116448 WARNING: CreateLoader - unsupported protocol(music@smb) in music@smb://plitvice/music/HIRES/4-Non-Blondes/Bigger-Better-Faster-More/1_3_4-Non-Blondes_Whats-Up_6.flac
–> Is working fine.
2.
2020-01-22 18:21:18.594 T:3824116448 WARNING: CreateLoader - unsupported protocol(music@smb) in music@smb://plitvice/music/HIRES/Bob-Marley-and-The-Wailers/Legend-The-Best-Of-Bob-Marley-and-The-Wailers/1_1_Bob-Marley-and-The-Wailers_Is-This-Love_7.flac
–> Is not working (played but with no sound)

Thanks.

Can you try with your GUI set to 1080p, please?

Yes, same problem.

Can you post a clip of a file you can’t play, please?

Maybe mediainfo as well, I got no issues playing 24bit 192kHz flacs or even multi channel at 24bit 96kHz flacs.

1 Like
<setting id="audiooutput.audiodevice">ALSA:default</setting>
...
====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
Dobly_Digital+, 8 ch, 32/44.1/48 kHz,  bit
ReferToStreamHeader, 1 ch, kHz,  bit

---------------------- Audio Cap END --------------- k3dRrf31

My ideas to this:

  1. Have you changed the device ouput to an appropriate setting at Settings->System->Audio?

  2. the connected audio device (a Samsung TV?) seems to support up to 24-bit 48 kHz, only. So, in case of a higher sampled 2-ch flac audio, this could be a reason …?!

Addition:

There was a try to play something this device might not be able to handle

Jan 22 18:21:17 mediacenter kernel: aml_spdif_dai: aml_hw_iec958_init,runtime->rate=96000, runtime->channels=2, same source mode(1), stream format=1
Jan 22 18:21:17 mediacenter kernel: aml_spdif_dai: set divider = 2 for i2s shared clock
Jan 22 18:21:17 mediacenter kernel: aml_audio_hw: IEC958 PCM32
Jan 22 18:21:17 mediacenter kernel: hdmitx: audio: aout notify rate 96000
Jan 22 18:21:17 mediacenter kernel: hdmitx: audio: aout notify size 32
Jan 22 18:21:17 mediacenter kernel: hdmitx: audio: hdmi_ch: 0 speaker_layout: 0
Jan 22 18:21:17 mediacenter kernel: hdmitx: audio: no update

It is a 96,000 Hz audio and according to the audio cap the connected device (Samsung TV?) is not able to process this sample rate. Also the timestamp 18:21:17 matches to the try playing the flac of Marley + Wailers.

According to the logs the 4-Non-Blondes flac is 44.1 kHz sampled which the device can process.

You could configure the mediacenter+Vero to resample all(!!!) audio signals (except the passthrough ones) to the max. sample rate your device can process like:

Yes, that was it !

I changed the output to “fixed” with the limit rate to 48 Khz and it works.

Thanks a lot for your help ! Great community.

1 Like