Playing Mkv files on the vero 4k

Hi there…I have a Vero 4k that i have had a few months now…apart from the latest update i have installed nothing on it,All i use it for is watching movies from a Ext HD…these being in MKV format.

sometimes when i am playing a movie it will suddenly freeze…when i re-run the movie it will freeze again at exactly the same point in the movie.Therefore it is a clitch/error within the movie and not the box…

If i run the same movie on say a ps3/Multiman or on a pc they will just except the clitch/error and move on,but that is not so for me on the 4k box

My question is…Is that the way it is or do i need to install a movie player/app on the 4k box… TIA

Different decoders have different tolerances to bugs in videos.

You can try remuxing the video, playing it in software or resourcing it. It shouldn’t be a common occurrence

What do you mean sam by “playing it in software”…is there a addon player that i can put on the vero box ?

Try disabling amcodec for H264.

Ultimately this is a workaround. If the file is bad, the file is bad.

where do i find amcodec sam in the system ?

Settings, player - its under the Processing Header

Still keep getting this happen on many movies i play and it happens in random places throughout the movie… ive done a log file of where it happens (20:00:42.427) there seems to be a few warnings and errors in the script,i just wondered if they are ok .

You can check your files for errors with ffmpeg

For example: ffmpeg -v error -i movie.mkv -f null -

just a quick update on this problem and how i solved the problem…

I drag the mkv files over to MKVtoolnix in there the chapters are removed.and the file then plays spot on…ive done this plenty of times now so its not just a coincidence…it would always crash also when you try to step forward or back in the movie…but once them chapters are out it perfect…

That sounds like an issue with the video. Usually remuxing it – as you have done, is a good enough solution.


Sam ive not really remuxed it…is it multiplexing…a 4 gig file takes about 2mins and just removes the subtitles…where if i put it through say handbrake then it would be a remux and take ages

No – Handbrake is a transcoder.
Extracting the streams and putting them in a new container (which is what you’ve done) is remuxing.

Right ok …Many thanks…Well it done the job for me just fine