Playing music causes Vero4K+ (kodi) to freeze

I recently purchased a Vero 4K+ and I am still finding my way around it. There are so many things that it does automatically that I find myself being impressed with the integration with my TV and home stereo amp. :smiley:

I’ve run into a few issues that thanks to the forum and my own linux knowledge, I have been able to resolve. But this one is causing me frustration. Any help or advice is appreciated.

Eps and Films play just fine. Music, however, has many issues. Some are interface related and may be due to my inexperience with Kodi/Vero. example: The option auto-play next doesn’t seem to work.

The one issue that it making music playback impossible is when I select a file to play, it quite often stops part way through and the whole kodi interface locks up. The display on the TV just freezes, the remote doesn’t respond. Turning the TV off does not put the Vero into suspend as it usually does in this situation. I can recover the Vero by logging in via SSH and issuing a ‘reboot’. Sometimes playback will just pause for 10 secs to a minute and then continue. Other times I get a light blue screen with an unhappy face on it where after a time Kodi will restart.

My music library is only 23k+ songs at the moment and is sitting on an exFAT 5TB USB 3.0 external drive that is attached via the OSMC powered hub that I bought with the Vero4K+. My movies are also sitting on another such drive and have no troubles playing 4K films. (I’m watching one now as I type this) - I have tested the drive that the music is stored on via another system and there are no errors, transfer speed is up to spec (135MB/s - USB3) and all files are readable. VLC plays the files just fine under windows.

Currently these external USB drives are being auto-mounted under /media. I would like to mount them permanently under /mnt but have not yet been able to accomplish that. My adding them to /etc/fstab using UUID’s only caused the Vero to go into emergency boot mode. (I recovered from that just fine though)

I have installed the recent OSMC November update and just this morning there were additional updates that I also installed. I still have the same issues as described above.

Any assistance is appreciated.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I have the debug logging turned on and will get right on the following steps. Thanks!

ok - this time the music continued play until the end of the track (and did not continue to the next track) but the Kodi interface froze in the middle. (even the debug info stopped updating)

The logs are available here: https://paste.osmc.tv/oxoquhinix

In the last log, it looks like something is requesting Kodi to exit.

Hmmm. I do not know what could have made that request. I have my amp (Onkyo) connected via SPDIF, my TV (Samsung 2020 The Frame model) via HDMI, network (gigabit), and at that time the remote dongle in the white USB and the OSMC 4 port power USB hub in the black USB port. My USB drives were all connected via the powered hub.

I was playing a song with full debugging turned on. As I said, the TV image froze about 3 minutes into the song but the audio continued playing until the end of the song and then didn’t continue. The SSH session I had running was idle, just waiting until I needed to create the logs.

I have been continuing to experiment with this and I am wondering if I am asking/expecting too much from the Vero. I have 4 5TB external HD’s that I was planning to connect. Really, it seems that one might be too much - at least with my music library on it.

I have moved a single drive to the white USB port, split my music library into a flatter directory structure and moved the remote dongle to the USB hub. I am using no other HD’s at the moment and still kodi chokes on scanning my music library. I have to reboot or, lately, actually power-off /on the Vero and then try scanning again.

These external drives (2.5inch) are designed for USB2 but I dug into the power usage and although Seagate doesn’t easily publish the info, I found a site that stated that their measurements were that the drive could draw up to 4.2watts. That’s over the 500mA, I know. And , yet, the single drive is working in the white USB port (where I wrote about 200+GB to the drive) - Oh, and as part of my trial-and-error testing, I formatted another drive and copied the entire music library to it from the original source, just in case there was a problem with the 1st music drive. No joy. Same issues.

And all of this only seems to be messing with music. Playing films works fine. Still exploring. I have lots of questions but won’t ask them in this thread.

How shall we proceed? What’s my next step? As this is a new install, I’m perfectly willing to wipe and re-install, should that be necessary.

That will work - but are those hard drives externally powered? The hub won’t be able to provide enough power alone to these drives without changing the PSU.

Yeah, I figured that out and that’s why I was only playing with two of them. But even just two of them seem to already have problems. It’s as if the USB bus freezes. I can continue to access the root fs but attempts to access the USB attached storage results in the session waiting forever. “ls -la” I can Ctrl-C out of but a “df -h” is death for the ssh session. I have to start a new ssh session.

I’m currently playing music from one of these 5TB drive directly attached to the white USB port. Not going through the hub. So far, so good. This is with the flatter music directory structure. I did have troubles scanning though, as I mentioned in my previous post.

As to using a different PSU for the hub… Can it handle that? I’ve got enough various power bricks around here that I am sure I can find one with higher amperage but the same voltage.

Higher amperage is fine - just don’t mix voltage.

Your issue could also be a problematic / faulty hard drive.

Yes, I took that into account when testing. HDD-1 was were I originally had my music library. I now have it on HDD-3 and the issues had remained when it was attached to the USB hub. Again, now that I have the music drive (HDD-3) on the white USB directly attached, the music has been playing all night without issue.

Today I am going to attach just one HDD (movies/eps) to the USB hub and see if both drives and kodi continue to function normally. If so, then I will go hunting for a higher amperage (same voltage) PSU for the hub before adding any additional HD’s.

I’ll report back as I get more data. Thanks for your time and assistance so far.

Update:

I bought a different USB hub. USB3.0 with a 12v 2amp PSU - (Nedis UHUBUP3510BK) and have replaced the OSMC hub. So far, the issues that I was having with the USB channels locking up is now gone. The current setup is, 1 Seagate 5TB external (2.5 inch) is conneted directly to the Vero 4K+ (USB white port). The rest of the drives (same type) and the remote dongle are all connected via the Nedis USB hub which is attached to the black USB port.

Music playing, however, was still an issue. After preciesly 3 minutes from the last action from the remote, the TV display would freeze. The SSH sessions and FTP continued to function. The Web interface would respond but no commands to the player would work. (ie. I could change pages but any attempt to play, stop, pause did not work) The only recovery was to Stop and Start Mediacenter with systemctl.

Step-by-step I went through various settings:

Screensaver was set at 3 minutes and “Black”. I tried setting to None and re-testing. I tried setting to default and re-testing. Freezes continued.

But! Under Player->Music->Visualization I removed PictureIt and set it to None. The freezes seem to have gone away.

It would seem that I had two issues at once. Always fun to find those.

  • osmc hub
  • PictureIt causing problems

I hope this can help other and thanks for your time. If you have any recommendation or suggestions with regards to PictureIt or other plug-ins/options, I welcome them.