Playing/Streaming videos does not work anymore (Disney, OneDrive)


i use DisneyPlus and OneDrive Addon to stream videos.
Everything worked fine until yesterday: During an ongoing stream on disney the video interrupted and could not be continued. Now when i want to start a stream on disney OR onedrive, the stream starts for 1 or 2 seconds and then the screen is freezing (no audio also). I can go back to the menu but the behaviour is always the same when i want to start a new video.

With activated debugging i can see this error when it comes to the screen freeze:
error : CDVDVideoCodecDRMPRIME::AddData - send packet failed: End of file

Here the full log file when starting a video from onedrive:

Appreciate any support…

As requested here the full logfile from osmc logfile uploader:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, i updated my initial post with the requested log file


Are you able to try with a different power supply?

Regards Tom.

Hi Tom,
thanks for that hint. Unfortunately ist doesnt work either. I tried it with two other Power supplies.


Logs suggest if it isn’t a bad psu, it could be a failing sd card. I would back up your settings and install on a fresh sd card and restore your settings.

Regards Tom.

Thanks Tom. That helped. It is running now.

1 Like