Plex add-on not saving login

This is really just a notification because I don’t even know where to start with fixing this. Although it was working fine some recent update broke my Plex for Kodi add-on functionality. It works but every time I start it up I have to sign back into Plex using the four digit code and the settings don’t stick. Even though I set it to automatically start Plex when the system restarts for example it doesn’t work anymore.

I thought perhaps it was an update on the Plex for Kodi add-on side but it’s still version .21 so I don’t think that has changed.

I don’t know that anyone here can do anything about it or even cares but if anyone has any ideas I’m all ears.

Moved to its own thread as I doubt this is related to the 3D thread. Providing logs would probably be appropriate.

EDIT: Tried to reproduce on my RPi running staging so Buster and 4.9 kernel so I believe this is the same as the current 3D build minus the 3D and i’m not able to reproduce this behavior. I opened and then exited Plex for Kodi three times, rebooted, and then repeated three more times. It automatically logged me in and brought up my library each time. My Plex server is running on Windows and is up to date.

1 Like

I’m not at my computer right now but I will Try to send logs shortly.

The reason I originally posted it in the test build thread for 3-D is because it was working fine until maybe the last week. I assumed, perhaps incorrectly, that it was related to something that changed in that build and the devs might wanna know about it.

I just tried to upload logs and this is what happened. I got yelled at by a Dev a couple of weeks ago for posting a picture of the URL instead of the actual URL, but there’s nothing to post.

If I recall there’s a way to upload logs via CLI. I’ll see if I can find the instructions to do that.

Reboot twice and try to upload again.

1 Like

That worked!


I don’t know if this will make a difference with Plex, but you don’t have Wait for Network enabled.

Not sure what you mean by that.

In My OSMC > Network > Wired (or wireless) and select Wait for Network.

I also have a second log after I turned logging back on…:wink:

Perhaps unrelated, but having the Vero plugged in right next to a Roku ultra on the same switch, the Vero stutters playing 4K. I get a buffering message every 10 seconds or so. Playing the exact same movie from the same Plex server on the Roku ultra I have no issues at all.

If it matters i’ve played many 4K films on the same Vero plugged into the same switch from the same Plex server without issue. This is a new issue as well. If it persists I’ll start a new thread.

I don’t know Plex very well, but from the logs it appears that you are using transcode. You probably don’t need that.

Something interesting in the log:

2020-11-03 20:37:50.165 T:3676041440   ERROR: GetDirectory - Error getting plugin://script.plex/

Maybe your Plex install is corrupt. You could try re-installing it.

And maybe even deleting that add-ons settings as well…

rm ~/.kodi/userdata/addon_data/script.plex/settings.xml

Awesome! The bonehead in me didn’t even think of this, but it worked! It is saving my login info again and starts automatically as i set it to. Why didn’t I think of that!!??

I definitely do not. Not sure what you are referring to with “appears you are using transcode”. In OSMC, within the PfK add-on I have all the video options enables…direct play, HEVC etc over a 1GB LAN. AFAIK, whether it transcodes or not is up to some negotiation between the player and the server based on the capabilities of the player and the bandwidth available. I don’t know if there is a setting specifically for that.

I don’t know if it was still transcoding or not. My Plex server and my Vero are not in the same room so I didn’t look at the server to see if it was transcoding or not, but after removing the PfK add-on, rebooting then setting it up again even my buffering issue is gone and PQ is great again!

I’m guessing that the PfK add-on got corrupted somehow and reinstalling it fixed the issue. Since I play through that add-on it may have affected the negotiation with the Plex server, hosing usability somehow and forcing it to transcode.

The PfK add-on still lives and is being developed for Kodi 19 as well:

If you go to in a web browser you can access your server and when it is playing you can click on an icon in the top right of the web page to view the activity. This will show you how it is streaming and if any transcoding is going on.

1 Like

Yes, this is what I was alluding to with my comment about my PC not being near my Vero. I know how to check this, but didn’t have access at the time it was having issues.

I REALLY wish they would add this sort of functionality to the Plex iOS app. Not that I’m thinking about it I wonder if PlexDash has this capability. I don’t use it often, but it’s a cool app that can tell you more about the details of what’s happening with your media. In trying it right now it tells me bandwidth/CPU etc, but I don’t see any indication of whether it’s transcoding to my Windows PC using Plex Media Player. I’ll have to dig into that more…

Thanks everyone for the help as always!

iOS has a web browser

1 Like

It does, but I’d still like to see them add this functionality to the native apps. I remember a couple years ago about the plan to add more admin functions to it, but haven’t seen much.