Plex for Kodi no longer sees Plex server

I know that officially speaking this is a Kodi thing. I just know this group is often a higher IQ version of the Kodi forum…

My Vero 4K+ has been working great for months and months using the PfK add-on. Recently I had to rebuild my Plex server because the DB was completely corrupt. I rebuilt it using the same name as it had before thinking that would be the simple option. Since I’ve done this though I can no longer connect through the app. I have gone so far as to completely delete the app, restart the Vero, reinstall and re-authorize. It just times out when I try to connect to the server.

Any thoughts?

Maybe a firewall issue on the Plex system.

Can you reach your new Plex installation from anywhere other than the computer it is installed on?

Is your PfK connection going directly to the Plex server or out via the Plex internet service?

1 Like

I can reach my Plex server from every client but this one and one LG smart TV at my BIL’s house a few miles away which is remote. I can even reach it on my phone when NOT on the LAN. My Plex server shows “fully accessible” OUTSIDE my network as well, but since this Vero is connected via Ethernet on the same LAN as the server and all my other LAN clients work (some I had to clear cache or tinker with a little when I rebuilt the server) it does seem to be related to this Vero client.

As far as the PfK connection going straight to the server or not, I’d imagine at this point it is trying to hit the Plex site for initial account validation since that was all wiped out. I can in fact do that fine. It just times out when trying to actually connect to the server. Uninstalling the add-on, rebooting the box then reinstalling it and logging back in actually gave me the normal user login with my home users listed. When I logged into my user it still wouldn’t see the local server. It did allow me to access the offsite server of a friend though which of course then became the “default” server since it’s the only one it could connect to. If I try to manually reconnect to my internal server it just times out.

In your Plex server settings check that secure connections are only set to “prefered” and that local discovery in on. If you have IPv6 turned on then you might try with it off. In you PKC settings you also might check how the security settings are set. If you did a Plex server upgrade in this process this might have changed something. I got a notice from Plex recently informing me that the encryption settings on older clients now had to be disabled so I know something changed in this regard. The warning they sent me was regarding an older TV that was accessing my server and not a Kodi client, but it is probably worth looking at.

OK, these settings were already as you mentioned.

I had two clients that couldn’t connect. One was the Vero4K+ through PfK on the local network. The other was a remote smart TV at my BIL’s house that connected fine prior to me rebuilding my Plex server. I didn’t upgrade server versions during this process as it was on the latest already, but what did seem to fix the issue in BOTH cases was to re-enable “Manually specify public port” in the server Remote Access settings. I run a UniFi network at home and do have the 32400 port forwarded to my server internally. I must have had that set before, but it was so long ago when I set it up I didn’t recall. All the clients on the LAN of course could see it without issue and even my iPhone could see it while on cell data, but for some reason the Vero could not and that one remote client could not.

Still trying to wrap my head around this given it’s an internal client on my LAN, but perhaps it has something to do with how the PfK add-on works?

1 Like

I would have expected local discovery to work without a WAN link but Plex can be a bit finicky sometimes. Unifi controllers have UPnP disabled by default (as it should be) so you would have needed to have the port number manually set in the Plex server settings. Another thing to look out for with Plex and Unifi is using guest networks. I would think that a guest (ie port isolation) would be able to just access the local Plex server via the internet but apparently Unifi’s firewall is smart enough to know your routing back to the same LAN and blocks it.

Glad you got it going again.