Poor video quality for h.264 IPTV stream from with hardware acceleration

Hi everyone,

I am using OSMC to watch IPTV streams (German IPTV provider “Entertain”) with a TVHeadend instance (separate RPi). The streams are H.264 format. I’m using TVHeadend 3.4.27 and OSMC November Update 11.2. This worked well until end of November.

Since a few days, IPTV streams are being rendered with very poor quality - lots of artifacts After some investigation I tried turning hardware acceleration completely off (no MMAL and no OMXPlayer); after that quality was OK. But HD streams then become laggy and therefore unsuable. Playback of a recorded stream shows the same symptoms - changing the container from TS to MKV also does not help. Only chance I found so far was to convert the video stream; which does not help for the Live TV stream.

Here’s “mediainfo” output for a recorded stream with the described issues.

Has anybody similar experiences …? Anything I can do from OSMC/KODI/RPi side …?

Thanks and best regards

Does the corruption look like this:

(there is a link to a file which plays corrupt).
If so we are aware of the issue and it’s being investigated.


looks exactly like my IPTV streams. Also, the symptom descriptions on Github match my situation.

Do you need anything from me …? I also have a recording (~44M) which I could upload somewhere, if needed.


If you upload the video (e.g.to dropbox or google drive) and post a link on the github issue, then it will be tested with any fix being developed, so improves the chance that you will be happy with the fix.

Just posted two links on GitHub. Thanks.


The issue on Github has been fixed and closed. I manually changed the firmware files and everything is well.
Now I am wondering which OSMC update will pick up that fix - could somebody shed some light into this?


We normally include a Raspberry Pi firmware update in the monthly updates - whatever is the most current version at the time of the update, so it should get updated in approximately a weeks time.

cc @sam_nazarko

Are you referring to this issue?


Yes, exactly.


Okay – thanks for letting us know. I’ll update the firmware for the January update.